summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-06-25 06:59:00 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-06-25 06:59:00 +0000
commit01d311b90d5bf2c2b898b9b378102e366a39edc6 (patch)
tree5c718f5ce397275757657a4047133cb833af448f /net-libs/webkit-gtk
parentAdd ~amd64; #228339 (diff)
downloadgentoo-2-01d311b90d5bf2c2b898b9b378102e366a39edc6.tar.gz
gentoo-2-01d311b90d5bf2c2b898b9b378102e366a39edc6.tar.bz2
gentoo-2-01d311b90d5bf2c2b898b9b378102e366a39edc6.zip
Version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r3 i686)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p34753.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index f0c8f05072f4..f35075969ac4 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.4 2008/06/14 14:20:29 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.5 2008/06/25 06:59:00 jokey Exp $
+
+*webkit-gtk-0_p34753 (25 Jun 2008)
+
+ 25 Jun 2008; Markus Ullmann <jokey@gentoo.org>
+ +webkit-gtk-0_p34753.ebuild:
+ Version bump
11 Jun 2008; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Fix Header
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p34753.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p34753.ebuild
new file mode 100644
index 000000000000..1dba7f2645e1
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-0_p34753.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p34753.ebuild,v 1.1 2008/06/25 06:59:00 jokey Exp $
+
+inherit autotools
+
+MY_P="WebKit-r${PV/0\_p}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkit.org/"
+SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="coverage debug gstreamer hildon pango soup sqlite svg xslt"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ dev-libs/icu
+ >=net-misc/curl-7.15
+ media-libs/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ sqlite? ( >=dev-db/sqlite-3 )
+ gstreamer? (
+ >=media-libs/gst-plugins-base-0.10
+ >=gnome-base/gnome-vfs-2.0
+ )
+ soup? ( >=net-libs/libsoup-2.4 )
+ xslt? ( dev-libs/libxslt )
+ pango? ( x11-libs/pango )"
+
+DEPEND="${RDEPEND}
+ dev-util/gperf
+ dev-util/pkgconfig
+ virtual/perl-Text-Balanced"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ use pango && myconf="${myconf} --with-font-backend=pango"
+ use soup && myconf="${myconf} --with-http-backend=soup"
+
+ econf \
+ $(use_enable sqlite database) \
+ $(use_enable sqlite icon-database) \
+ $(use_enable sqlite dom-storage) \
+ $(use_enable sqlite offline-web-applications) \
+ $(use_enable gstreamer video) \
+ $(use_enable svg) \
+ $(use_enable debug) \
+ $(use_with hildon) \
+ $(use_enable xslt) \
+ $(use_enable coverage) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}