summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-07 04:11:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-07 04:11:23 +0000
commit259a11e341b05df95cabfbbe020d72fd7e89fab8 (patch)
tree932e0afdccdf95297d85fa089a634247a3ed3a6a /net-libs/nodejs
parentVersion bump. (diff)
downloadgentoo-2-259a11e341b05df95cabfbbe020d72fd7e89fab8.tar.gz
gentoo-2-259a11e341b05df95cabfbbe020d72fd7e89fab8.tar.bz2
gentoo-2-259a11e341b05df95cabfbbe020d72fd7e89fab8.zip
Bump for #460492, rewritten ebuild by Johan Bergstroem
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.9.12.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 081f659868a8..256da7262089 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.73 2013/03/06 03:43:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.74 2013/03/07 04:11:23 patrick Exp $
+
+*nodejs-0.9.12 (07 Mar 2013)
+
+ 07 Mar 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.9.12.ebuild:
+ Bump for #460492, rewritten ebuild by Johan Bergstroem
*nodejs-0.8.21 (06 Mar 2013)
diff --git a/net-libs/nodejs/nodejs-0.9.12.ebuild b/net-libs/nodejs/nodejs-0.9.12.ebuild
new file mode 100644
index 000000000000..c321a062d356
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.9.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.9.12.ebuild,v 1.1 2013/03/07 04:11:23 patrick Exp $
+
+EAPI=5
+
+# a few tests fail. Should be fixed in 0.10
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/python-json
+ test? ( net-misc/curl )"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr --openssl-use-sys --shared-zlib || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${ED}"
+
+ dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}