summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-03-01 11:12:42 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-03-01 11:12:42 +0000
commitbc30922cb346b04567507a99f05a9dd99afc8f1e (patch)
treecb62bc5fdd769c9006c18bc500111b7fffab8b48 /net-libs/libtorrent
parentstable x86, bug 211021 (diff)
downloadgentoo-2-bc30922cb346b04567507a99f05a9dd99afc8f1e.tar.gz
gentoo-2-bc30922cb346b04567507a99f05a9dd99afc8f1e.tar.bz2
gentoo-2-bc30922cb346b04567507a99f05a9dd99afc8f1e.zip
Version Bump wrt bug #209361
Add ipv6 use flag wrt bug #207581 (Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog9
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.0.ebuild43
2 files changed, 51 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 1d1aa87c4734..3a7ddb95c804 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.110 2008/02/06 20:55:41 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.111 2008/03/01 11:12:42 drizzt Exp $
+
+*libtorrent-0.12.0 (01 Mar 2008)
+
+ 01 Mar 2008; Timothy Redaelli <drizzt@gentoo.org>
+ +libtorrent-0.12.0.ebuild:
+ Version Bump wrt bug #209361
+ Add ipv6 use flag wrt bug #207581
06 Feb 2008; nixnut <nixnut@gentoo.org> libtorrent-0.11.9.ebuild:
stable on ppc wrt bug #209140
diff --git a/net-libs/libtorrent/libtorrent-0.12.0.ebuild b/net-libs/libtorrent/libtorrent-0.12.0.ebuild
new file mode 100644
index 000000000000..5cf019a725b7
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.0.ebuild,v 1.1 2008/03/01 11:12:42 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug ipv6"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ --enable-static \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}