summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-10-21 02:55:12 +0000
committerChris Reffett <creffett@gentoo.org>2012-10-21 02:55:12 +0000
commita0910d1d7f92a29fecf7828bca4b87ca18f94e17 (patch)
tree1baff07365291a9c671ac1d7e683fac7a03caf46 /net-libs/libproxy
parentAdd snapshot to tree from live ebuild. (diff)
downloadgentoo-2-a0910d1d7f92a29fecf7828bca4b87ca18f94e17.tar.gz
gentoo-2-a0910d1d7f92a29fecf7828bca4b87ca18f94e17.tar.bz2
gentoo-2-a0910d1d7f92a29fecf7828bca4b87ca18f94e17.zip
Add automoc to DEPEND per bug 438714
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/ChangeLog7
-rw-r--r--net-libs/libproxy/libproxy-0.4.10-r1.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 5f40a425d8d4..cb28510774a5 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.86 2012/10/19 06:35:28 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.87 2012/10/21 02:55:12 creffett Exp $
+
+*libproxy-0.4.10-r1 (21 Oct 2012)
+
+ 21 Oct 2012; Chris Reffett <creffett@gentoo.org> +libproxy-0.4.10-r1.ebuild:
+ Add automoc to DEPEND per bug 438714
19 Oct 2012; Andreas Schuerch <nativemad@gentoo.org> libproxy-0.4.10.ebuild:
x86 stable, see bug 438146
diff --git a/net-libs/libproxy/libproxy-0.4.10-r1.ebuild b/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..1960d03b9ce8
--- /dev/null
+++ b/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10-r1.ebuild,v 1.1 2012/10/21 02:55:12 creffett Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit cmake-utils eutils mono python
+
+DESCRIPTION="Library for automatic proxy configuration management"
+HOMEPAGE="http://code.google.com/p/libproxy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="gnome kde mono networkmanager perl python spidermonkey test webkit"
+
+# NOTE: mozjs/spidermonkey might still cause problems like #373397 ?
+# NOTE: webkit-gtk:3, not :2, needed for libjavascriptcoregtk support
+RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
+ kde? ( >=kde-base/kdelibs-4.4.5 )
+ mono? ( dev-lang/mono )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( dev-lang/perl )
+ spidermonkey? ( >=dev-lang/spidermonkey-1.8.5 )
+ webkit? ( >=net-libs/webkit-gtk-1.6:3 )"
+DEPEND="${RDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Gentoo's spidermonkey doesn't set Version: in mozjs185.pc
+ epatch "${FILESDIR}/${PN}-0.4.10-mozjs185.pc.patch"
+
+ # get-pac-test freezes when run by the ebuild, succeeds when building
+ # manually; virtualx.eclass doesn't help :(
+ epatch "${FILESDIR}/${PN}-0.4.10-disable-pac-test.patch"
+}
+
+src_configure() {
+ # WITH_VALA just copies the .vapi file over and needs no deps,
+ # hence always enable it unconditionally
+ local mycmakeargs=(
+ -DPERL_VENDORINSTALL=ON
+ -DCMAKE_C_FLAGS="${CFLAGS}"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
+ $(cmake-utils_use_with gnome GNOME3)
+ $(cmake-utils_use_with kde KDE4)
+ $(cmake-utils_use_with mono DOTNET)
+ $(cmake-utils_use_with networkmanager NM)
+ $(cmake-utils_use_with perl PERL)
+ $(cmake-utils_use_with python PYTHON)
+ $(cmake-utils_use_with spidermonkey MOZJS)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with webkit WEBKIT3)
+ -DWITH_VALA=ON
+ $(cmake-utils_use test BUILD_TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}