summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-09-26 03:57:36 +0000
committerChris Reffett <creffett@gentoo.org>2012-09-26 03:57:36 +0000
commit6c3c5371cb1940bb1cc9abb7ba570e571ad4d19d (patch)
tree2538c29ffb45bdae9b4a86c0ded183164e459e6a /net-libs/libkolabxml
parentLicense fix. (diff)
downloadgentoo-2-6c3c5371cb1940bb1cc9abb7ba570e571ad4d19d.tar.gz
gentoo-2-6c3c5371cb1940bb1cc9abb7ba570e571ad4d19d.tar.bz2
gentoo-2-6c3c5371cb1940bb1cc9abb7ba570e571ad4d19d.zip
Version bump to 0.8.1
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libkolabxml')
-rw-r--r--net-libs/libkolabxml/ChangeLog7
-rw-r--r--net-libs/libkolabxml/libkolabxml-0.8.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/libkolabxml/ChangeLog b/net-libs/libkolabxml/ChangeLog
index 4f26ec95a052..ee7b5f1097a1 100644
--- a/net-libs/libkolabxml/ChangeLog
+++ b/net-libs/libkolabxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libkolabxml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.3 2012/09/26 03:50:58 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.4 2012/09/26 03:57:36 creffett Exp $
+
+*libkolabxml-0.8.1 (26 Sep 2012)
+
+ 26 Sep 2012; Chris Reffett <creffett@gentoo.org> +libkolabxml-0.8.1.ebuild:
+ Version bump to 0.8.1
26 Sep 2012; Chris Reffett <creffett@gentoo.org> libkolabxml-0.8.0.ebuild:
License fix.
diff --git a/net-libs/libkolabxml/libkolabxml-0.8.1.ebuild b/net-libs/libkolabxml/libkolabxml-0.8.1.ebuild
new file mode 100644
index 000000000000..57c4e52f9a3b
--- /dev/null
+++ b/net-libs/libkolabxml/libkolabxml-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-0.8.1.ebuild,v 1.1 2012/09/26 03:57:36 creffett Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Kolab XML format schema definitions library"
+HOMEPAGE="http://www.kolab.org"
+SRC_URI="http://mirror.kolabsys.com/pub/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 as-is LGPL-3+ public-domain"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="csharp java python php test"
+
+RDEPEND="
+ dev-cpp/xsd
+ || ( >=dev-libs/boost-1.42.0 ( <dev-libs/boost-1.42.0 dev-libs/ossp-uuid ) )
+ dev-libs/xerces-c
+"
+DEPEND="
+ ${RDEPEND}
+ csharp? ( >=dev-lang/swig-2.0.7 dev-lang/mono )
+ java? ( >=dev-lang/swig-2.0.7 virtual/jre )
+ php? ( >=dev-lang/swig-2.0.7 dev-lang/php )
+ python? ( >=dev-lang/swig-2.0.7 dev-lang/python )
+ test? ( x11-libs/qt-test:4 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use csharp CSHARP_BINDINGS)
+ $(cmake-utils_use java JAVA_BINDINGS)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ $(cmake-utils_use php PHP_BINDINGS)
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}