summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-20 13:53:31 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-20 13:53:31 +0000
commit7075f886f49a0d6503cdd222c106dac1af2395f1 (patch)
tree333dd5880c0e4e32bf236c994c644e7d6a75fec7 /net-libs/libisds/libisds-0.4.ebuild
parentVersion bump, thank krigstask for report. Note, shared roster ldap module (US... (diff)
downloadgentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.tar.gz
gentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.tar.bz2
gentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.zip
Remove old. Fix tests and use autotools-utils eclass.
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libisds/libisds-0.4.ebuild')
-rw-r--r--net-libs/libisds/libisds-0.4.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/net-libs/libisds/libisds-0.4.ebuild b/net-libs/libisds/libisds-0.4.ebuild
index 35561f38f4d1..8e2b35f5175f 100644
--- a/net-libs/libisds/libisds-0.4.ebuild
+++ b/net-libs/libisds/libisds-0.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.4.ebuild,v 1.1 2010/12/20 10:57:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.4.ebuild,v 1.2 2010/12/20 13:53:30 scarabeus Exp $
EAPI=3
[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base ${GIT}
+inherit autotools-utils ${GIT}
DESCRIPTION="Client library for accessing ISDS Soap services"
HOMEPAGE="http://xpisar.wz.cz/libisds/"
@@ -40,15 +40,25 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
- base_src_prepare
+ autotools-utils_src_prepare
[[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-fatalwarnings \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ "--disable-fatalwarnings"
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable static-libs static)
$(use_enable test)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # hack for failing gnupg testing
+ export HOME="${T}"
+ mkdir "${HOME}/.gnupg"
+ autotools-utils_src_test
}