summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-11-08 21:29:54 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-11-08 21:29:54 +0000
commit315374743382308e386528ed85d79550bd6224f8 (patch)
treed05b9ca29dd6f9c0a39b4234fb2f9cf34214829d /net-libs/libetpan
parentInitial import; replaces nx-x11 and nx-x11-bin (diff)
downloadgentoo-2-315374743382308e386528ed85d79550bd6224f8.tar.gz
gentoo-2-315374743382308e386528ed85d79550bd6224f8.tar.bz2
gentoo-2-315374743382308e386528ed85d79550bd6224f8.zip
Version bump.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog7
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.483
-rw-r--r--net-libs/libetpan/libetpan-0.48.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index d1b248d2b396..271f0bd6f8cd 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.37 2006/10/20 21:16:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.38 2006/11/08 21:29:54 ticho Exp $
+
+*libetpan-0.48 (08 Nov 2006)
+
+ 08 Nov 2006; Andrej Kacian <ticho@gentoo.org> +libetpan-0.48.ebuild:
+ Version bump.
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> libetpan-0.45.ebuild:
Stable on Alpha.
diff --git a/net-libs/libetpan/files/digest-libetpan-0.48 b/net-libs/libetpan/files/digest-libetpan-0.48
new file mode 100644
index 000000000000..be36dd9d014e
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.48
@@ -0,0 +1,3 @@
+MD5 493de1bfc84c1e0f82fd865795e48ffb libetpan-0.48.tar.gz 1018656
+RMD160 bf7190d3235df21a344eaf5f79e38b31f681f12a libetpan-0.48.tar.gz 1018656
+SHA256 039861766d330b8ff2309334feb97d384e16d927dd859fdc0fad4c4a13d66b7c libetpan-0.48.tar.gz 1018656
diff --git a/net-libs/libetpan/libetpan-0.48.ebuild b/net-libs/libetpan/libetpan-0.48.ebuild
new file mode 100644
index 000000000000..ca7fac6a31f0
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.48.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.48.ebuild,v 1.1 2006/11/08 21:29:54 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb debug gnutls sasl ssl ipv6"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with sasl` \
+ `use_enable ipv6` \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-0.47."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}