summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-28 17:57:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-28 17:57:49 +0000
commitc02a1623ed76810f386a89a6fbb52ad9bc926609 (patch)
tree7c524361b3ee27c8becec5a86f5e92e9d8dc135c /net-libs/libasyncns
parentDrop realplayer support, security bug 232999, moving real codecs to media-lib... (diff)
downloadgentoo-2-c02a1623ed76810f386a89a6fbb52ad9bc926609.tar.gz
gentoo-2-c02a1623ed76810f386a89a6fbb52ad9bc926609.tar.bz2
gentoo-2-c02a1623ed76810f386a89a6fbb52ad9bc926609.zip
Long overdue version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r1 x86_64)
Diffstat (limited to 'net-libs/libasyncns')
-rw-r--r--net-libs/libasyncns/ChangeLog7
-rw-r--r--net-libs/libasyncns/libasyncns-0.7.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libasyncns/ChangeLog b/net-libs/libasyncns/ChangeLog
index 1cb31d58e36d..2f0b05ec321c 100644
--- a/net-libs/libasyncns/ChangeLog
+++ b/net-libs/libasyncns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libasyncns
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.11 2008/08/07 09:39:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.12 2008/10/28 17:57:49 flameeyes Exp $
+
+*libasyncns-0.7 (28 Oct 2008)
+
+ 28 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> +libasyncns-0.7.ebuild:
+ Long overdue version bump.
*libasyncns-0.4 (07 Aug 2008)
diff --git a/net-libs/libasyncns/libasyncns-0.7.ebuild b/net-libs/libasyncns/libasyncns-0.7.ebuild
new file mode 100644
index 000000000000..a9000456aaa6
--- /dev/null
+++ b/net-libs/libasyncns/libasyncns-0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.7.ebuild,v 1.1 2008/10/28 17:57:49 flameeyes Exp $
+
+inherit libtool flag-o-matic
+
+DESCRIPTION="C library for executing name service queries asynchronously."
+HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"
+SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
+
+SLOT="0"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc debug"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+
+ elibtoolize
+}
+
+src_compile() {
+ # libasyncns uses assert()
+ use debug || append-flags -DNDEBUG
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --disable-dependency-tracking \
+ --disable-lynx \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ doxygen doxygen/doxygen.conf || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc; then
+ docinto apidocs
+ dohtml html/*
+ fi
+}