summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-22 22:27:52 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-22 22:27:52 +0000
commitabae7e0f77ae9060741ce9ec9249ad50573e35c2 (patch)
tree13edb68f41dc119e980bb8cdd4e873a2e6b8774d /net-libs/gupnp
parentAdd gupnp-vala to gupnp-dlna mask since it depends on it (diff)
downloadgentoo-2-abae7e0f77ae9060741ce9ec9249ad50573e35c2.tar.gz
gentoo-2-abae7e0f77ae9060741ce9ec9249ad50573e35c2.tar.bz2
gentoo-2-abae7e0f77ae9060741ce9ec9249ad50573e35c2.zip
Version bump. Enable gzip compression, dropped dependency on dbus-glib.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/ChangeLog7
-rw-r--r--net-libs/gupnp/gupnp-0.15.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/net-libs/gupnp/ChangeLog b/net-libs/gupnp/ChangeLog
index d5a1b0cb5338..64b6b97a0c15 100644
--- a/net-libs/gupnp/ChangeLog
+++ b/net-libs/gupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.33 2011/01/11 05:36:26 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.34 2011/02/22 22:27:52 eva Exp $
+
+*gupnp-0.15.1 (22 Feb 2011)
+
+ 22 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-0.15.1.ebuild:
+ Version bump. Enable gzip compression, dropped dependency on dbus-glib.
11 Jan 2011; Arun Raghavan <ford_prefect@gentoo.org> gupnp-0.13.2.ebuild:
Clarify gssdp dep as per bug #326805
diff --git a/net-libs/gupnp/gupnp-0.15.1.ebuild b/net-libs/gupnp/gupnp-0.15.1.ebuild
new file mode 100644
index 000000000000..2a2a0d6c8a8a
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.15.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.15.1.ebuild,v 1.1 2011/02/22 22:27:52 eva Exp $
+
+EAPI=3
+
+DESCRIPTION="an object-oriented framework for creating UPnP devs and control points."
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection networkmanager"
+
+RDEPEND=">=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=dev-libs/glib-2.24:2
+ dev-libs/libxml2
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ networkmanager? ( >=dev-libs/glib-2.26 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ local backend=unix
+ use networkmanager && backend=network-manager
+
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --with-context-manager=${backend} \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}