summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-25 17:09:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-25 17:09:26 +0000
commit8d05e42735d845baad0a4f01d8f0caa6d2ccfc97 (patch)
tree85efe3438a556fdb41696e8d610bc0b0359959d3 /net-libs/gupnp-igd
parentStable for x86, wrt bug #444686 (diff)
downloadgentoo-2-8d05e42735d845baad0a4f01d8f0caa6d2ccfc97.tar.gz
gentoo-2-8d05e42735d845baad0a4f01d8f0caa6d2ccfc97.tar.bz2
gentoo-2-8d05e42735d845baad0a4f01d8f0caa6d2ccfc97.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs/gupnp-igd')
-rw-r--r--net-libs/gupnp-igd/ChangeLog7
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index 6bf13d743817..6705717ba044 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.39 2012/10/01 08:29:14 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.40 2012/11/25 17:09:26 eva Exp $
+
+*gupnp-igd-0.2.2 (25 Nov 2012)
+
+ 25 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-igd-0.2.2.ebuild:
+ Version bump.
01 Oct 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> gupnp-igd-0.2.1.ebuild:
x86 stable wrt bug #434300
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild
new file mode 100644
index 000000000000..51cf05d7bb8b
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild,v 1.1 2012/11/25 17:09:26 eva Exp $
+
+EAPI="5"
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit autotools eutils gnome.org python
+
+DESCRIPTION="This is a library to handle UPnP IGD port mapping for GUPnP."
+HOMEPAGE="http://gupnp.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection python"
+
+RDEPEND="
+ >=net-libs/gupnp-0.18
+ >=dev-libs/glib-2.16:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? ( >=dev-python/pygobject-2.16:2 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# The only existing test is broken
+RESTRICT="test"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
+
+ # Python bindings are built/installed manually.
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am
+
+ eautoreconf
+
+ python_clean_py-compile_files -q
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-gtk-doc \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_compile() {
+ # introspection is built in the same directory and libtool does not handle
+ # well dependency like this
+ MAKEOPTS="${MAKEOPTS} -j1" default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS README TODO"
+
+ default
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize gupnp
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup gupnp
+ fi
+}