summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-07-22 21:08:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-07-22 21:08:01 +0000
commit9836bc90d7ce56a78bc1f3662c4670db29e391cd (patch)
tree5e7e4d8ca034891d1d69d591c7f992f523141d71 /net-libs/gupnp-av
parentKeyword ~ppc64, bug #381749 (diff)
downloadgentoo-2-9836bc90d7ce56a78bc1f3662c4670db29e391cd.tar.gz
gentoo-2-9836bc90d7ce56a78bc1f3662c4670db29e391cd.tar.bz2
gentoo-2-9836bc90d7ce56a78bc1f3662c4670db29e391cd.zip
Version bump.
(Portage version: 2.2.0_alpha117/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/ChangeLog7
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.10.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/gupnp-av/ChangeLog b/net-libs/gupnp-av/ChangeLog
index 55353e47704a..55a0c13d9160 100644
--- a/net-libs/gupnp-av/ChangeLog
+++ b/net-libs/gupnp-av/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-av
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.16 2012/05/05 02:54:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.17 2012/07/22 21:08:01 eva Exp $
+
+*gupnp-av-0.10.2 (22 Jul 2012)
+
+ 22 Jul 2012; Gilles Dartiguelongue <eva@gentoo.org +gupnp-av-0.10.2.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> gupnp-av-0.8.0.ebuild,
gupnp-av-0.10.1.ebuild:
diff --git a/net-libs/gupnp-av/gupnp-av-0.10.2.ebuild b/net-libs/gupnp-av/gupnp-av-0.10.2.ebuild
new file mode 100644
index 000000000000..8d66fcadd22b
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.10.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.10.2.ebuild,v 1.1 2012/07/22 21:08:01 eva Exp $
+
+EAPI="4"
+
+inherit gnome.org
+
+DESCRIPTION="A small utility library that aims to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=net-libs/gupnp-0.17[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-static \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
+}
+
+src_install() {
+ default
+ # Remove pointless .la files
+ find "${D}" -name '*.la' -delete
+}