summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-09-26 12:51:40 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-09-26 12:51:40 +0000
commitc39ce8807b619bd1d22507aa42e4c4a0694962f9 (patch)
tree122b27dece027df1b64bfe0f9c1e69511dcc41d3 /net-libs/gsoap
parentAdd new gpsd_protocols desc file for gpsd ebuild. (diff)
downloadgentoo-2-c39ce8807b619bd1d22507aa42e4c4a0694962f9.tar.gz
gentoo-2-c39ce8807b619bd1d22507aa42e4c4a0694962f9.tar.bz2
gentoo-2-c39ce8807b619bd1d22507aa42e4c4a0694962f9.zip
Version bump.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog7
-rw-r--r--net-libs/gsoap/gsoap-2.8.0.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 71215be6d6df..b313f94e06c2 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.11 2010/06/27 16:03:18 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.12 2010/09/26 12:51:40 polynomial-c Exp $
+
+*gsoap-2.8.0 (26 Sep 2010)
+
+ 26 Sep 2010; Lars Wendler <polynomial-c@gentoo.org> +gsoap-2.8.0.ebuild:
+ Version bump. Still no fix for failing parallel make (-j > 1).
27 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> gsoap-2.7.17.ebuild:
Adding missing dependency on app-arch/unzip.
diff --git a/net-libs/gsoap/gsoap-2.8.0.ebuild b/net-libs/gsoap/gsoap-2.8.0.ebuild
new file mode 100644
index 000000000000..4ac306a05a2f
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.0.ebuild,v 1.1 2010/09/26 12:51:40 polynomial-c Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples +ssl static-libs"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # causes compilation of app-emulation/virtualbox-ose[vboxwebsrv] to
+ # break (bug #320901):
+ #epatch "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ $(use_enable examples samples) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}