summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:15:43 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:15:43 +0000
commit036bd44363132ddd57c079231e1101469e226728 (patch)
tree0016cb90defab7a2c0bfe97f72a024013ee6c8a0 /net-libs/gloox
parentAdded ~ppc wrt bug 204813 (diff)
downloadgentoo-2-036bd44363132ddd57c079231e1101469e226728.tar.gz
gentoo-2-036bd44363132ddd57c079231e1101469e226728.tar.bz2
gentoo-2-036bd44363132ddd57c079231e1101469e226728.zip
Version bump wrt bug #213404 thanks to Steffen Stramm for the new ebuild and David Watzke for the patch
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/ChangeLog9
-rw-r--r--net-libs/gloox/files/gloox-res_query-check.patch11
-rw-r--r--net-libs/gloox/gloox-0.9.9.4.ebuild43
3 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/gloox/ChangeLog b/net-libs/gloox/ChangeLog
index 6b482d6988c5..d8ede0e4dee7 100644
--- a/net-libs/gloox/ChangeLog
+++ b/net-libs/gloox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gloox
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.6 2008/03/10 15:02:10 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.7 2008/03/18 21:15:42 jokey Exp $
+
+*gloox-0.9.9.4 (18 Mar 2008)
+
+ 18 Mar 2008; Markus Ullmann <jokey@gentoo.org>
+ +files/gloox-res_query-check.patch, +gloox-0.9.9.4.ebuild:
+ Version bump wrt bug #213404 thanks to Steffen Stramm for the new ebuild and
+ David Watzke for the patch
10 Mar 2008; Steve Dibb <beandog@gentoo.org> gloox-0.9.8.ebuild:
amd64 stable, bug 202261
diff --git a/net-libs/gloox/files/gloox-res_query-check.patch b/net-libs/gloox/files/gloox-res_query-check.patch
new file mode 100644
index 000000000000..91dcfebd2ecd
--- /dev/null
+++ b/net-libs/gloox/files/gloox-res_query-check.patch
@@ -0,0 +1,11 @@
+--- configure.ac~ 2008-02-18 21:30:35.000000000 +0100
++++ configure.ac 2008-02-18 21:31:21.000000000 +0100
+@@ -248,7 +248,7 @@
+ AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
+ save_libs="$LIBS"
+ LIBS="-lresolv $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0)]])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_RES_QUERY)
+ have_res_query=yes],
diff --git a/net-libs/gloox/gloox-0.9.9.4.ebuild b/net-libs/gloox/gloox-0.9.9.4.ebuild
new file mode 100644
index 000000000000..7dfddc0d035a
--- /dev/null
+++ b/net-libs/gloox/gloox-0.9.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.4.ebuild,v 1.1 2008/03/18 21:15:42 jokey Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-res_query-check.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}