summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-12-21 22:43:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-12-21 22:43:26 +0000
commit911a6271a27ed8e5ce77603c5bb45f35637379b0 (patch)
tree9e0a7ab79284dfd61670c732ce04e418b9f2689f /net-libs/farsight2
parentApply changes suggested by Arfrever for multiply python slots support, bug #3... (diff)
downloadgentoo-2-911a6271a27ed8e5ce77603c5bb45f35637379b0.tar.gz
gentoo-2-911a6271a27ed8e5ce77603c5bb45f35637379b0.tar.bz2
gentoo-2-911a6271a27ed8e5ce77603c5bb45f35637379b0.zip
Add support for multiple python slots, bug #349239.
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/farsight2')
-rw-r--r--net-libs/farsight2/ChangeLog5
-rw-r--r--net-libs/farsight2/farsight2-0.0.20.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/net-libs/farsight2/ChangeLog b/net-libs/farsight2/ChangeLog
index d199e4f1682f..c8be0e45e107 100644
--- a/net-libs/farsight2/ChangeLog
+++ b/net-libs/farsight2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/farsight2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.38 2010/11/21 00:52:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.39 2010/12/21 22:43:26 eva Exp $
+
+ 21 Dec 2010; Gilles Dartiguelongue <eva@gentoo.org> farsight2-0.0.20.ebuild:
+ Add support for multiple python slots, bug #349239.
20 Nov 2010; Michael Weber <xmw@gentoo.org> farsight2-0.0.17.ebuild,
farsight2-0.0.20.ebuild:
diff --git a/net-libs/farsight2/farsight2-0.0.20.ebuild b/net-libs/farsight2/farsight2-0.0.20.ebuild
index 7de93ab586ca..6fc8451c0991 100644
--- a/net-libs/farsight2/farsight2-0.0.20.ebuild
+++ b/net-libs/farsight2/farsight2-0.0.20.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.20.ebuild,v 1.4 2010/11/21 00:52:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.20.ebuild,v 1.5 2010/12/21 22:43:26 eva Exp $
EAPI="2"
-inherit autotools eutils
+PYTHON_DEPEND="2"
+
+inherit autotools eutils python
DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
HOMEPAGE="http://farsight.freedesktop.org/"
@@ -19,10 +21,10 @@ RESTRICT=test
COMMONDEPEND=">=media-libs/gstreamer-0.10.26
>=media-libs/gst-plugins-base-0.10.26
- >=dev-libs/glib-2.16
+ >=dev-libs/glib-2.16:2
>=net-libs/libnice-0.0.9[gstreamer]
python? (
- >=dev-python/pygobject-2.16
+ >=dev-python/pygobject-2.16:2
>=dev-python/gst-python-0.10.10 )
upnp? ( net-libs/gupnp-igd )"
@@ -36,6 +38,10 @@ DEPEND="${COMMONDEPEND}
media-plugins/gst-plugins-speex )
dev-util/pkgconfig"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-make-382.patch
eautoreconf