summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-25 20:40:20 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-25 20:40:20 +0000
commitdcef3bd68254bfe31cf3668d96fd27d96b24cb03 (patch)
treea1f3cf944e5d833024bf0a62142f04e070b4538c /net-irc
parentadded quirc until we can sort it (diff)
downloadgentoo-2-dcef3bd68254bfe31cf3668d96fd27d96b24cb03.tar.gz
gentoo-2-dcef3bd68254bfe31cf3668d96fd27d96b24cb03.tar.bz2
gentoo-2-dcef3bd68254bfe31cf3668d96fd27d96b24cb03.zip
new package
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quirc/ChangeLog10
-rw-r--r--net-irc/quirc/files/digest-quirc-0.9.821
-rw-r--r--net-irc/quirc/quirc-0.9.82.ebuild55
3 files changed, 66 insertions, 0 deletions
diff --git a/net-irc/quirc/ChangeLog b/net-irc/quirc/ChangeLog
new file mode 100644
index 000000000000..82c58aa1fb0e
--- /dev/null
+++ b/net-irc/quirc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-irc/quirc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quirc/ChangeLog,v 1.1 2002/04/25 20:40:20 seemant Exp $
+
+*quirc-0.9.82 (25 Apr 2002)
+
+ 25 Apr 2002; Semant Kulleen <seemant@gentoo.org> quirc-0.9.82.ebuild
+ files/digest-quirc-0.9.82
+
+ New package added to portage.
diff --git a/net-irc/quirc/files/digest-quirc-0.9.82 b/net-irc/quirc/files/digest-quirc-0.9.82
new file mode 100644
index 000000000000..b2f95ef70d4c
--- /dev/null
+++ b/net-irc/quirc/files/digest-quirc-0.9.82
@@ -0,0 +1 @@
+MD5 4148739f4cf66458bd5355d6196772cb quirc-0.9.82.tar.gz 296135
diff --git a/net-irc/quirc/quirc-0.9.82.ebuild b/net-irc/quirc/quirc-0.9.82.ebuild
new file mode 100644
index 000000000000..dc746a996877
--- /dev/null
+++ b/net-irc/quirc/quirc-0.9.82.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dmitriy Kropivnitskiy <nigde@mitechki.net> aka Jeld The Dark Elf
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quirc/quirc-0.9.82.ebuild,v 1.1 2002/04/25 20:40:20 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GUI IRC client scriptable in Tcl/Tk"
+SRC_URI="http://quirc.org/${P}.tar.gz"
+HOMEPAGE="http://quirc.org/"
+
+DEPEND="dev-lang/tcl
+ dev-lang/tk"
+
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/quirc \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ distdir=${D}/usr/share/quirc \
+ pkgdatadir=${D}/usr/share \
+ install || die
+
+ # this package's install script is a little screwy so we need to move things
+ # around a bit in the ${D} directory
+ dodir /usr/share/quirc
+ mv ${D}${D}usr/share/* ${D}/usr/share/quirc
+
+ insinto /usr/share/quirc/common
+ doins ${S}/data/common/*
+
+ insinto /usr/share/quirc/themes
+ doins ${S}/data/themes/*
+
+ # this package installs docs, but we would rather do that ourselves
+ dodoc README NEWS INSTALL FAQ ChangeLog* COPYING AUTHORS
+ dodoc doc/*
+
+ #clean up from package's messy install
+ rm -rf ${D}${D}
+ rm -rf ${D}/usr/doc
+ rm -rf ${D}usr/share/common
+ rm -rf ${D}usr/share/themes
+}