summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-06 12:58:46 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-06 12:58:46 +0000
commitcadb5ba9c11e0e3ff9cc429ff931ae24a010d82d (patch)
tree61b36e7fe34c0a6af111fb5cf80698566e4776c7 /net-irc
parentmove gtk+ apps to /usr and use gtk+-1.2.10-r4, #4 (diff)
downloadgentoo-2-cadb5ba9c11e0e3ff9cc429ff931ae24a010d82d.tar.gz
gentoo-2-cadb5ba9c11e0e3ff9cc429ff931ae24a010d82d.tar.bz2
gentoo-2-cadb5ba9c11e0e3ff9cc429ff931ae24a010d82d.zip
now compiles too :)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/xchat-1.8.2-r2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-irc/xchat/xchat-1.8.2-r2.ebuild b/net-irc/xchat/xchat-1.8.2-r2.ebuild
index 32da90700dfb..99c7a7a30a68 100644
--- a/net-irc/xchat/xchat-1.8.2-r2.ebuild
+++ b/net-irc/xchat/xchat-1.8.2-r2.ebuild
@@ -1,7 +1,7 @@
# Copyrigth 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.2-r2.ebuild,v 1.1 2001/10/06 10:08:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.2-r2.ebuild,v 1.2 2001/10/06 12:58:46 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="xchat irc client"
@@ -19,6 +19,11 @@ RDEPEND=">=x11-libs/gtk+-1.2.8
gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_unpack() {
+ unpack ${A}
+}
+
src_compile() {
local myopts myflags
@@ -26,10 +31,12 @@ src_compile() {
use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
use ssl && myopts="$myopts --enable-openssl"
use perl && myopts="$myopts --disable-perl"
- use python && myflags="`python-config --libs`"
+ use python && myflags="`python-config --libs` -lm"
use python || myopts="$myopts --disable-python"
use nls || myopts="$myopts --disable-nls"
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
if [ "$myflags" ] ; then