summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-10-08 10:20:12 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-10-08 10:20:12 +0000
commitc317358478ffea965c301edd63d366cc23cbb66c (patch)
tree9249276f1615afb330d091d75777cb55357ee5f8 /net-irc
parentRemove old. (diff)
downloadgentoo-2-c317358478ffea965c301edd63d366cc23cbb66c.tar.gz
gentoo-2-c317358478ffea965c301edd63d366cc23cbb66c.tar.bz2
gentoo-2-c317358478ffea965c301edd63d366cc23cbb66c.zip
Version bump, adds stability & build fixes compared to the earlier beta.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/conspire/ChangeLog7
-rw-r--r--net-irc/conspire/conspire-1.0.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index 4a5b3648acaa..40e9fe6e7502 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/conspire
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.12 2009/08/11 19:50:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.13 2009/10/08 10:20:12 chainsaw Exp $
+
+*conspire-1.0.0 (08 Oct 2009)
+
+ 08 Oct 2009; <chainsaw@gentoo.org> +conspire-1.0.0.ebuild:
+ Version bump, adds stability & build fixes compared to the earlier beta.
11 Aug 2009; Christian Faulhammer <fauli@gentoo.org> conspire-0.20.ebuild:
stable x86, bug 277906
diff --git a/net-irc/conspire/conspire-1.0.0.ebuild b/net-irc/conspire/conspire-1.0.0.ebuild
new file mode 100644
index 000000000000..faf93852e7c9
--- /dev/null
+++ b/net-irc/conspire/conspire-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-1.0.0.ebuild,v 1.1 2009/10/08 10:20:12 chainsaw Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )
+ dev-util/pkgconfig"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libnotify
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}