summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-09-26 21:39:10 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-09-26 21:39:10 +0000
commitab05cd23bd1367ba6865877a5f29844ba178e86e (patch)
treee81922ffe71d3e92ee72d1c98734913f7ee43d54 /net-irc
parentppc64 stable wrt #338340 (diff)
downloadgentoo-2-ab05cd23bd1367ba6865877a5f29844ba178e86e.tar.gz
gentoo-2-ab05cd23bd1367ba6865877a5f29844ba178e86e.tar.bz2
gentoo-2-ab05cd23bd1367ba6865877a5f29844ba178e86e.zip
Install python plugin in proper location & build against newer GTK+. Both requests by Diego E. "Flameeyes" Pettenò, closes bugs #323109 & #330701.
(Portage version: 2.2_rc87/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/conspire/ChangeLog10
-rw-r--r--net-irc/conspire/conspire-1.0.1.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index 40e9fe6e7502..81005305da12 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/conspire
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.13 2009/10/08 10:20:12 chainsaw Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.14 2010/09/26 21:39:10 chainsaw Exp $
+
+*conspire-1.0.1 (26 Sep 2010)
+
+ 26 Sep 2010; <chainsaw@gentoo.org> +conspire-1.0.1.ebuild:
+ Install python plugin in proper location & build against newer GTK+. Both
+ requests by Diego E. "Flameeyes" Pettenò, closes bugs #323109 & #330701.
*conspire-1.0.0 (08 Oct 2009)
diff --git a/net-irc/conspire/conspire-1.0.1.ebuild b/net-irc/conspire/conspire-1.0.1.ebuild
new file mode 100644
index 000000000000..5a5b0ffa02e4
--- /dev/null
+++ b/net-irc/conspire/conspire-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-1.0.1.ebuild,v 1.1 2010/09/26 21:39:10 chainsaw Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )
+ dev-util/pkgconfig"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libnotify
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}