summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-13 14:24:37 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-13 14:24:37 +0000
commit4067ed16d57af085e09adf15e045e9ed7b211da4 (patch)
tree93bb0690a885b67269c26e756d19677dffe05f6b /net-irc
parentVersion bump to 2.00e and closing bug #150300. (diff)
downloadgentoo-2-4067ed16d57af085e09adf15e045e9ed7b211da4.tar.gz
gentoo-2-4067ed16d57af085e09adf15e045e9ed7b211da4.tar.bz2
gentoo-2-4067ed16d57af085e09adf15e045e9ed7b211da4.zip
Include patch to make xchat-remote invoke the correct binary, should fix bug #143688.
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/xchat-2.6.6-suffix.patch12
-rw-r--r--net-irc/xchat/xchat-2.6.6.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index bf51559fe386..c194fc745398 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.211 2006/09/26 20:03:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.212 2006/10/13 14:24:37 swegener Exp $
+
+ 13 Oct 2006; Sven Wegener <swegener@gentoo.org>
+ +files/xchat-2.6.6-suffix.patch, xchat-2.6.6.ebuild:
+ Include patch to make xchat-remote invoke the correct binary, should fix bug
+ #143688.
26 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> xchat-2.6.6.ebuild:
Stable on hppa wrt #134652
diff --git a/net-irc/xchat/files/xchat-2.6.6-suffix.patch b/net-irc/xchat/files/xchat-2.6.6-suffix.patch
new file mode 100644
index 000000000000..bf5ac2fafcc0
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.6.6-suffix.patch
@@ -0,0 +1,12 @@
+diff -Nur xchat-2.6.6.orig/plugins/dbus/xchat-remote.c xchat-2.6.6/plugins/dbus/xchat-remote.c
+--- xchat-2.6.6.orig/plugins/dbus/xchat-remote.c 2006-07-15 08:27:21.000000000 +0000
++++ xchat-2.6.6/plugins/dbus/xchat-remote.c 2006-10-13 14:16:57.801263851 +0000
+@@ -110,7 +110,7 @@
+ if (fork() == 0)
+ {
+ gchar *url = g_strdup_printf ("--url=%s", opt_open_url);
+- execl (PREFIX"/bin/"PACKAGE_TARNAME, PACKAGE_TARNAME, "-a", url, NULL);
++ execl (PREFIX"/bin/"PACKAGE_TARNAME"-2", PACKAGE_TARNAME"-2", "-a", url, NULL);
+ }
+ } else
+ write_error (_("Failed to complete command"), error);
diff --git a/net-irc/xchat/xchat-2.6.6.ebuild b/net-irc/xchat/xchat-2.6.6.ebuild
index 24fd52fa8d1c..1ffb54de3daa 100644
--- a/net-irc/xchat/xchat-2.6.6.ebuild
+++ b/net-irc/xchat/xchat-2.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.6.ebuild,v 1.7 2006/09/26 20:03:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.6.ebuild,v 1.8 2006/10/13 14:24:37 swegener Exp $
inherit eutils versionator gnome2
@@ -34,6 +34,7 @@ src_unpack() {
cd "${S}"
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+ epatch "${FILESDIR}"/xchat-2.6.6-suffix.patch
# use libdir/xchat/plugins as the plugin directory
if [ $(get_libdir) != "lib" ] ; then