summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-23 15:46:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-23 15:46:00 +0000
commit3b67815a258d992d6570191a7d892daa9070d8af (patch)
tree85a70b4485b72905c9ff7658d454cb9309ef7c04 /net-irc
parent Sync to branch, fixes linking and desktop entry standard comliance issues. (diff)
downloadgentoo-2-3b67815a258d992d6570191a7d892daa9070d8af.tar.gz
gentoo-2-3b67815a258d992d6570191a7d892daa9070d8af.tar.bz2
gentoo-2-3b67815a258d992d6570191a7d892daa9070d8af.zip
Install rbot without rubygems, don't build locale files if they are not requested, remove mandatory dep over ruby-gettext at both build and runtime.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/rbot/ChangeLog10
-rw-r--r--net-irc/rbot/rbot-9999-r9.ebuild (renamed from net-irc/rbot/rbot-9999-r8.ebuild)142
2 files changed, 78 insertions, 74 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index f4691507d942..b2b3a52fec84 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.30 2008/06/23 15:08:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.31 2008/06/23 15:46:00 flameeyes Exp $
+
+*rbot-9999-r9 (23 Jun 2008)
+
+ 23 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> -rbot-9999-r8.ebuild,
+ +rbot-9999-r9.ebuild:
+ Install rbot without rubygems, don't build locale files if they are not
+ requested, remove mandatory dep over ruby-gettext at both build and
+ runtime.
23 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> rbot-9999-r8.ebuild:
Add new flags to IUSE.
diff --git a/net-irc/rbot/rbot-9999-r8.ebuild b/net-irc/rbot/rbot-9999-r9.ebuild
index 2acd9682e20d..aca7a4e6f24c 100644
--- a/net-irc/rbot/rbot-9999-r8.ebuild
+++ b/net-irc/rbot/rbot-9999-r9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r8.ebuild,v 1.3 2008/06/23 15:08:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r9.ebuild,v 1.1 2008/06/23 15:46:00 flameeyes Exp $
-inherit ruby gems eutils
+inherit ruby eutils
[[ ${PV} == "9999" ]] && inherit git
@@ -13,8 +13,8 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS=""
IUSE="spell aspell timezone translator shorturl nls dict figlet
- fortune cal host"
-ILINGUAS="zh ru nl de fr it en ja"
+ fortune cal host nls"
+ILINGUAS="zh_CN zh_TW ru nl de fr it ja"
for lang in $ILINGUAS; do
IUSE="${IUSE} linguas_${lang}"
@@ -34,21 +34,16 @@ RDEPEND=">=virtual/ruby-1.8
figlet? ( app-misc/figlet )
fortune? ( games-misc/fortune-mod )
cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
- host? ( net-dns/bind-tools )"
-DEPEND=""
+ host? ( net-dns/bind-tools )
+ nls? ( dev-ruby/ruby-gettext )"
+DEPEND="nls? ( dev-ruby/ruby-gettext )"
if [[ ${PV} == "9999" ]]; then
SRC_URI=""
EGIT_REPO_URI="git://ruby-rbot.org/rbot.git"
-
- DEPEND="${DEPEND}
- dev-ruby/rake
- app-arch/zip
- dev-ruby/ruby-gettext"
-
- IUSE="${IUSE} snapshot"
else
- SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.gem"
+ # wait for the new releases...
+ SRC_URI=""
fi
pkg_setup() {
@@ -67,30 +62,12 @@ src_unpack() {
}
src_compile() {
- [[ ${PV} == "9999" ]] || return 0
- rake makemo || die "locale generation failed"
- rake || die "Gem generation failed"
-}
-
-src_install() {
- if [[ ${PV} == "9999" ]]; then
- GEM_SRC="${S}/pkg/rbot-9999.gem"
- MY_P="${PN}-9999"
- else
- MY_P="${P}"
- fi
- gems_src_install
-
- diropts -o rbot -g nobody -m 0700
- keepdir /var/lib/rbot
-
- newinitd "${FILESDIR}/rbot.init" rbot
- newconfd "${FILESDIR}/rbot.conf" rbot
-
- local rbot_datadir="${D}/${GEMSDIR}"/gems/${MY_P}/data/rbot
-
disable_rbot_plugin() {
- mv "${rbot_datadir}"/plugins/$1.rb{,.disabled}
+ mv "${S}"/data/rbot/plugins/$1.rb{,.disabled}
+ }
+ use_rbot_plugin() {
+ use $1 && return
+ disable_rbot_plugin "$2"
}
if ! use spell; then
@@ -100,52 +77,71 @@ src_install() {
# bad piece of code, at least give an opportunity to use
# something that works a bit better.
sed -i -e 's:ispell:ispell-aspell:' \
- "${rbot_datadir}"/plugins/spell.rb \
+ "${S}"/data/rbot/plugins/spell.rb \
|| die "Unable to replace ispell with aspell."
fi
- use timezone || disable_rbot_plugin time
- use translator || disable_rbot_plugin translator
- use shorturl || disable_rbot_plugin shortenurls
- use dict || disable_rbot_plugin dictclient
- use figlet || disable_rbot_plugin figlet
- use fortune || disable_rbot_plugin fortune
- use cal || disable_rbot_plugin cal
- use host || disable_rbot_plugin host
+ use_rbot_plugin timezone time
+ use_rbot_plugin translator translator
+ use_rbot_plugin shorturl shortenurls
+ use_rbot_plugin dict dictclient
+ use_rbot_plugin figlet figlet
+ use_rbot_plugin fortune fortune
+ use_rbot_plugin cal cal
+ use_rbot_plugin host host
+
+ local rbot_datadir="${D}"/usr/share/rbot
# This is unfortunately pretty manual at the moment, but it's just
# to avoid having to run special scripts to package new versions
# of rbot. The default if new languages are added that are not
# considered for an opt-out here is to install them, so you just
# need to add them later.
- strip-linguas ${ILINGUAS}
- if [[ -n ${LINGUAS} ]]; then
- # As the the language name used by the rbot data files does
- # not correspond to the ISO codes we usually use for LINGUAS,
- # the following list of local varables will work as a
- # dictionary to get the name used by rbot from the ISO code.
- local lang_rbot_zh="traditional_chinese"
- local lang_rbot_ru="russian"
- local lang_rbot_nl="dutch"
- local lang_rbot_de="german"
- local lang_rbot_fr="french"
- local lang_rbot_it="italian"
- local lang_rbot_en="english"
- local lang_rbot_ja="japanese"
-
- for lang in ${ILINGUAS}; do
- use linguas_${lang} && continue
-
- lang="lang_rbot_${lang}"
- lang_rbot=${!lang}
-
- rm \
- ${rbot_datadir}/languages/${lang_rbot}.lang \
- ${rbot_datadir}/templates/lart/larts-${lang_rbot} \
- ${rbot_datadir}/templates/lart/praises-${lang_rbot} \
- ${rbot_datadir}/templates/salut/salut-${lang_rbot}
- done
+ if use nls; then
+ strip-linguas ${ILINGUAS}
+ if [[ -n ${LINGUAS} ]]; then
+ # As the the language name used by the rbot data files does
+ # not correspond to the ISO codes we usually use for LINGUAS,
+ # the following list of local varables will work as a
+ # dictionary to get the name used by rbot from the ISO code.
+ local lang_rbot_zh_CN="traditional_chinese"
+ local lang_rbot_ru="russian"
+ local lang_rbot_nl="dutch"
+ local lang_rbot_de="german"
+ local lang_rbot_fr="french"
+ local lang_rbot_it="italian"
+ local lang_rbot_ja="japanese"
+
+ for lang in ${ILINGUAS}; do
+ use linguas_${lang} && continue
+
+ lang_varname="lang_rbot_${lang}"
+ lang_rbot=${!lang_varname}
+
+ rm -r \
+ "${S}"/data/rbot/languages/${lang_rbot}.lang \
+ "${S}"/data/rbot/templates/lart/larts-${lang_rbot} \
+ "${S}"/data/rbot/templates/lart/praises-${lang_rbot} \
+ "${S}"/data/rbot/templates/salut/salut-${lang_rbot} \
+ "${S}"/po/${lang}
+ done
+ fi
+
+ rake makemo || die "locale generation failed"
fi
+
+ ruby_econf || die "ruby_econf failed"
+}
+
+src_install() {
+ ${RUBY} setup.rb install --prefix="${D}" \
+ || die "setup.rb install failed"
+
+ diropts -o rbot -g nobody -m 0700
+ keepdir /var/lib/rbot
+
+ newinitd "${FILESDIR}/rbot.init" rbot
+ newconfd "${FILESDIR}/rbot.conf" rbot
}
pkg_postinst() {