summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-04-15 16:28:11 +0000
committerPacho Ramos <pacho@gentoo.org>2011-04-15 16:28:11 +0000
commit326c146a69861bbdf62155eb1d52cbb486dbdf55 (patch)
tree6f6cecdabffb1d722de7f10e61fced57e33af4df /net-irc
parentRe-add installing crontab file, bug 332901; Restore old crontab binary symlink (diff)
downloadgentoo-2-326c146a69861bbdf62155eb1d52cbb486dbdf55.tar.gz
gentoo-2-326c146a69861bbdf62155eb1d52cbb486dbdf55.tar.bz2
gentoo-2-326c146a69861bbdf62155eb1d52cbb486dbdf55.zip
Version bump with bugfixes.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/telepathy-idle/ChangeLog7
-rw-r--r--net-irc/telepathy-idle/telepathy-idle-0.1.9.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-irc/telepathy-idle/ChangeLog b/net-irc/telepathy-idle/ChangeLog
index 84b7d50bd44c..a57df60e19a0 100644
--- a/net-irc/telepathy-idle/ChangeLog
+++ b/net-irc/telepathy-idle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/telepathy-idle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/ChangeLog,v 1.26 2011/04/02 17:01:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/ChangeLog,v 1.27 2011/04/15 16:28:11 pacho Exp $
+
+*telepathy-idle-0.1.9 (15 Apr 2011)
+
+ 15 Apr 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-idle-0.1.9.ebuild:
+ Version bump with bugfixes.
*telepathy-idle-0.1.8 (02 Apr 2011)
diff --git a/net-irc/telepathy-idle/telepathy-idle-0.1.9.ebuild b/net-irc/telepathy-idle/telepathy-idle-0.1.9.ebuild
new file mode 100644
index 000000000000..81c441d77c1d
--- /dev/null
+++ b/net-irc/telepathy-idle/telepathy-idle-0.1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/telepathy-idle-0.1.9.ebuild,v 1.1 2011/04/15 16:28:11 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Full-featured IRC connection manager for Telepathy."
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Components"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2.8.6:2
+ >=dev-libs/openssl-0.9.7
+ >=net-libs/telepathy-glib-0.13.10
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-python/twisted-words )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS || die
+}