summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-06-21 23:30:48 +0000
committerSven Wegener <swegener@gentoo.org>2004-06-21 23:30:48 +0000
commit2f9e455c0ca6de0430208b1729bc7af8f75955f9 (patch)
treeaa66fcdf4523e8027521cb0f848331aa691cfa13 /net-irc
parentnew release, mark 2.0.0 x86 (Manifest recommit) (diff)
downloadgentoo-2-2f9e455c0ca6de0430208b1729bc7af8f75955f9.tar.gz
gentoo-2-2f9e455c0ca6de0430208b1729bc7af8f75955f9.tar.bz2
gentoo-2-2f9e455c0ca6de0430208b1729bc7af8f75955f9.zip
Modified the gcc34 patch to not change functionality. Made CFLAGS aware.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bnc/ChangeLog6
-rw-r--r--net-irc/bnc/bnc-2.8.6-r1.ebuild16
-rw-r--r--net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch25
3 files changed, 27 insertions, 20 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index bebf35aac9da..3cf3daaac379 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bnc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.8 2004/06/21 22:52:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.9 2004/06/21 23:30:48 swegener Exp $
+
+ 22 Jun 2004; Sven Wegener <swegener@gentoo.org>
+ files/bnc-2.8.6-gotofail-labelfix.patch, bnc-2.8.6-r1.ebuild:
+ Modified the gcc34 patch to not change functionality. Made CFLAGS aware.
22 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> +bnc-2.8.6-r1.ebuild files/bncsetup.patch:
Add patch to bncsetup, thanks to redeeman and GurliGebis.
diff --git a/net-irc/bnc/bnc-2.8.6-r1.ebuild b/net-irc/bnc/bnc-2.8.6-r1.ebuild
index 165d003a067c..4672b41694d5 100644
--- a/net-irc/bnc/bnc-2.8.6-r1.ebuild
+++ b/net-irc/bnc/bnc-2.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6-r1.ebuild,v 1.1 2004/06/21 22:52:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6-r1.ebuild,v 1.2 2004/06/21 23:30:48 swegener Exp $
inherit eutils
@@ -20,16 +20,22 @@ DEPEND="virtual/glibc"
S=${WORKDIR}/${MY_P}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
# fix gcc-3.4 compilation, bug #54689.
epatch ${FILESDIR}/bnc-2.8.6-gotofail-labelfix.patch
epatch ${FILESDIR}/bncsetup.patch
- econf || die
- emake || die
- mv mkpasswd bncmkpasswd
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake OPTS="${CFLAGS}" || die "emake failed"
}
src_install() {
+ mv mkpasswd bncmkpasswd
dodoc CHANGES README
dobin bnc bncchk bncsetup bncmkpasswd || die
insinto /usr/share/${MY_P}
diff --git a/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
index a4ced2e47223..b04f1e98419a 100644
--- a/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
+++ b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
@@ -1,26 +1,23 @@
-diff -Naur bnc2.8.6.orig/cmds.c bnc2.8.6/cmds.c
---- bnc2.8.6.orig/cmds.c 2002-07-13 04:48:13.000000000 +0200
-+++ bnc2.8.6/cmds.c 2004-06-21 23:32:49.057908144 +0200
-@@ -503,8 +503,8 @@
- tprintf(&cptr->loc, "NOTICE AUTH :Docked session %i\n", dptr->srv.fd);
+diff -u bnc2.8.6/cmds.c bnc2.8.6-gcc34/cmds.c
+--- bnc2.8.6/cmds.c 2002-07-13 02:48:13.000000000 +0000
++++ bnc2.8.6-gcc34/cmds.c 2004-06-21 23:16:39.809362023 +0000
+@@ -504,8 +504,8 @@
}
}
-- tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
- nodock:
-+ tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+ tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+-nodock:
}
++nodock:
tprintf(&cptr->loc, "NOTICE AUTH :type /quote help for basic list of commands and usage\n");
}
-@@ -1066,10 +1066,9 @@
- vhost = vhost_ptr->vhost;
+ return w;
+@@ -1067,8 +1067,8 @@
break;
}
-- }
+ }
-vfast_fail:
-+ }
}
--
+vfast_fail:
+
res = inet_aton(vhost, &addr);
if(res == 1)
- {