summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-02-21 07:44:44 +0000
committerAlex Alexander <wired@gentoo.org>2011-02-21 07:44:44 +0000
commit2c603d0d71c7b4662fae87e698bb35c70d0583e7 (patch)
treec35d975770e12d558a7ae63aa9f5b118f61d3e66 /net-irc
parentRemove old version. (diff)
downloadgentoo-2-2c603d0d71c7b4662fae87e698bb35c70d0583e7.tar.gz
gentoo-2-2c603d0d71c7b4662fae87e698bb35c70d0583e7.tar.bz2
gentoo-2-2c603d0d71c7b4662fae87e698bb35c70d0583e7.zip
updated SRC_URI, removed old patches
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog9
-rw-r--r--net-irc/znc/files/znc-0.090-null-pointer-dereference-fix.patch31
-rw-r--r--net-irc/znc/files/znc-0.092-dos-fix.patch89
-rw-r--r--net-irc/znc/znc-0.094.ebuild6
-rw-r--r--net-irc/znc/znc-0.096.ebuild6
5 files changed, 13 insertions, 128 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 45630ef02b5c..fbf4bcad6a6e 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.46 2010/11/08 18:08:03 wired Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.47 2011/02/21 07:44:44 wired Exp $
+
+ 21 Feb 2011; Alex Alexander <wired@gentoo.org>
+ -files/znc-0.090-null-pointer-dereference-fix.patch,
+ -files/znc-0.092-dos-fix.patch, znc-0.094.ebuild, znc-0.096.ebuild:
+ updated SRC_URI, removed old patches
08 Nov 2010; Alex Alexander <wired@gentoo.org> -znc-0.090-r1.ebuild,
-znc-0.092.ebuild, -znc-0.092-r1.ebuild:
diff --git a/net-irc/znc/files/znc-0.090-null-pointer-dereference-fix.patch b/net-irc/znc/files/znc-0.090-null-pointer-dereference-fix.patch
deleted file mode 100644
index c41e1fe9ed7b..000000000000
--- a/net-irc/znc/files/znc-0.090-null-pointer-dereference-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- trunk/znc.cpp 2010/06/13 07:58:28 2025
-+++ trunk/znc.cpp 2010/06/13 17:14:52 2026
-@@ -1927,18 +1927,18 @@
- }
-
- for (CSockManager::const_iterator it = m_Manager.begin(); it != m_Manager.end(); ++it) {
-+ CUser *pUser = NULL;
- if ((*it)->GetSockName().Left(5) == "IRC::") {
-- CIRCSock *p = (CIRCSock *) *it;
-- ret[p->GetUser()->GetUserName()].first += p->GetBytesRead();
-- ret[p->GetUser()->GetUserName()].second += p->GetBytesWritten();
-- uiUsers_in += p->GetBytesRead();
-- uiUsers_out += p->GetBytesWritten();
-+ pUser = ((CIRCSock *) *it)->GetUser();
- } else if ((*it)->GetSockName().Left(5) == "USR::") {
-- CClient *p = (CClient *) *it;
-- ret[p->GetUser()->GetUserName()].first += p->GetBytesRead();
-- ret[p->GetUser()->GetUserName()].second += p->GetBytesWritten();
-- uiUsers_in += p->GetBytesRead();
-- uiUsers_out += p->GetBytesWritten();
-+ pUser = ((CClient*) *it)->GetUser();
-+ }
-+
-+ if (pUser) {
-+ ret[pUser->GetUserName()].first += (*it)->GetBytesRead();
-+ ret[pUser->GetUserName()].second += (*it)->GetBytesWritten();
-+ uiUsers_in += (*it)->GetBytesRead();
-+ uiUsers_out += (*it)->GetBytesWritten();
- } else {
- uiZNC_in += (*it)->GetBytesRead();
- uiZNC_out += (*it)->GetBytesWritten();
diff --git a/net-irc/znc/files/znc-0.092-dos-fix.patch b/net-irc/znc/files/znc-0.092-dos-fix.patch
deleted file mode 100644
index a2688f4b1cfc..000000000000
--- a/net-irc/znc/files/znc-0.092-dos-fix.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff -u -r znc-0.092-orig//Client.cpp znc-0.092/Client.cpp
---- znc-0.092-orig//Client.cpp 2010-08-15 01:29:28.972436649 +0300
-+++ znc-0.092/Client.cpp 2010-08-15 01:30:34.721440283 +0300
-@@ -185,7 +185,10 @@
- // won't answer the ping (=no server connected) -> PONG back.
- // else: It's the server's job to send a PONG.
- if (sTarget.Equals("irc.znc.in") || !GetIRCSock()) {
-- PutClient("PONG " + sLine.substr(5));
-+ if (sLine.length() >= 5)
-+ PutClient("PONG " + sLine.substr(5));
-+ else
-+ PutClient(":irc.znc.in PONG irc.znc.in");
- return;
- }
- } else if (sCommand.Equals("PONG")) {
-diff -u -r znc-0.092-orig//IRCSock.cpp znc-0.092/IRCSock.cpp
---- znc-0.092-orig//IRCSock.cpp 2010-08-15 01:29:28.972436649 +0300
-+++ znc-0.092/IRCSock.cpp 2010-08-15 01:31:03.345456528 +0300
-@@ -87,7 +87,7 @@
- return;
- } else if (sLine.Equals("ERROR ", false, 6)) {
- //ERROR :Closing Link: nick[24.24.24.24] (Excess Flood)
-- CString sError(sLine.substr(7));
-+ CString sError(sLine.substr(6));
-
- if (sError.Left(1) == ":") {
- sError.LeftChomp();
-diff -u -r znc-0.092-orig//modules/adminlog.cpp znc-0.092/modules/adminlog.cpp
---- znc-0.092-orig//modules/adminlog.cpp 2010-08-15 01:29:28.970434898 +0300
-+++ znc-0.092/modules/adminlog.cpp 2010-08-15 01:31:13.639445703 +0300
-@@ -52,7 +52,7 @@
- if (sLine.Equals("ERROR ", false, 6)) {
- //ERROR :Closing Link: nick[24.24.24.24] (Excess Flood)
- //ERROR :Closing Link: nick[24.24.24.24] Killer (Local kill by Killer (reason))
-- CString sError(sLine.substr(7));
-+ CString sError(sLine.substr(6));
- if (sError.Left(1) == ":")
- sError.LeftChomp();
- Log("[" + m_pUser->GetUserName() + "] disconnected from IRC: " +
-diff -u -r znc-0.092-orig//modules/away.cpp znc-0.092/modules/away.cpp
---- znc-0.092-orig//modules/away.cpp 2010-08-15 01:29:28.970434898 +0300
-+++ znc-0.092/modules/away.cpp 2010-08-15 01:31:47.479451226 +0300
-@@ -390,7 +390,7 @@
- CBlowfish c(m_sPassword, BF_DECRYPT);
- sBuffer = c.Crypt(sFile);
-
-- if (sBuffer.substr(0, strlen(CRYPT_VERIFICATION_TOKEN)) != CRYPT_VERIFICATION_TOKEN)
-+ if (sBuffer.Left(strlen(CRYPT_VERIFICATION_TOKEN)) != CRYPT_VERIFICATION_TOKEN)
- {
- // failed to decode :(
- PutModule("Unable to decode Encrypted messages");
-diff -u -r znc-0.092-orig//modules/extra/email.cpp znc-0.092/modules/extra/email.cpp
---- znc-0.092-orig//modules/extra/email.cpp 2010-08-15 01:29:28.971434361 +0300
-+++ znc-0.092/modules/extra/email.cpp 2010-08-15 01:32:57.262438966 +0300
-@@ -154,7 +154,7 @@
-
- virtual void ReadLine(const CS_STRING & sLine)
- {
-- if (sLine.substr(0, 5) == "From ")
-+ if (sLine.Left(5) == "From ")
- {
- if (!m_sMailBuffer.empty())
- {
-@@ -168,7 +168,7 @@
- void ProcessMail()
- {
- EmailST tmp;
-- tmp.sUidl = (char *)CMD5(m_sMailBuffer.substr(0, 255));
-+ tmp.sUidl = (char *)CMD5(m_sMailBuffer.Left(255));
- VCString vsLines;
- VCString::iterator it;
-
-@@ -200,15 +200,7 @@
-
- void CEmail::OnModCommand(const CString& sCommand)
- {
-- CString::size_type iPos = sCommand.find(" ");
-- CString sCom, sArgs;
-- if (iPos == CString::npos)
-- sCom = sCommand;
-- else
-- {
-- sCom = sCommand.substr(0, iPos);
-- sArgs = sCommand.substr(iPos + 1, CString::npos);
-- }
-+ CString sCom = sCommand.Token(0);
-
- if (sCom == "timers")
- {
diff --git a/net-irc/znc/znc-0.094.ebuild b/net-irc/znc/znc-0.094.ebuild
index 4aec8e0ea1c0..c8aef92ab094 100644
--- a/net-irc/znc/znc-0.094.ebuild
+++ b/net-irc/znc/znc-0.094.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.094.ebuild,v 1.4 2010/08/28 23:31:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.094.ebuild,v 1.5 2011/02/21 07:44:44 wired Exp $
EAPI=2
@@ -8,7 +8,7 @@ inherit base
DESCRIPTION="An advanced IRC Bouncer"
HOMEPAGE="http://znc.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="http://znc.in/releases/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-irc/znc/znc-0.096.ebuild b/net-irc/znc/znc-0.096.ebuild
index 220b51862e98..a4068b2bd916 100644
--- a/net-irc/znc/znc-0.096.ebuild
+++ b/net-irc/znc/znc-0.096.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.096.ebuild,v 1.1 2010/11/08 07:59:02 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.096.ebuild,v 1.2 2011/02/21 07:44:44 wired Exp $
EAPI=2
@@ -8,7 +8,7 @@ inherit base
DESCRIPTION="An advanced IRC Bouncer"
HOMEPAGE="http://znc.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="http://znc.in/releases/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"