summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 11:24:23 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 11:24:23 +0000
commit1dd15e0a88ebc6975e2b2a8b99a6fdb3d765887a (patch)
tree3865659dbc172fdf9eea64ea221656ca4a53aa83 /net-irc
parentNLS fix submitted by seemant@rocketmail.com (Seemant Kulleen) and a dependenc... (diff)
downloadgentoo-2-1dd15e0a88ebc6975e2b2a8b99a6fdb3d765887a.tar.gz
gentoo-2-1dd15e0a88ebc6975e2b2a8b99a6fdb3d765887a.tar.bz2
gentoo-2-1dd15e0a88ebc6975e2b2a8b99a6fdb3d765887a.zip
new version
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog15
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.81
-rw-r--r--net-irc/xchat/xchat-1.8.8.ebuild61
3 files changed, 68 insertions, 9 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 79ffca9f9d3a..5e8e3c8eb1ee 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,13 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.1 2002/02/01 21:53:33 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.2 2002/03/10 11:24:23 blocke Exp $
-*xchat-1.8.7-r1 (1 Feb 2002)
+*xchat-1.8.8 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> xchat-1.8.8.ebuild :
+
+ Updated xchat to 1.8.8
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/net-irc/xchat/files/digest-xchat-1.8.8 b/net-irc/xchat/files/digest-xchat-1.8.8
new file mode 100644
index 000000000000..5713305d3a71
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.8
@@ -0,0 +1 @@
+MD5 8496a0438c1062d3d8f96f92d5e48a52 xchat-1.8.8.tar.bz2 735589
diff --git a/net-irc/xchat/xchat-1.8.8.ebuild b/net-irc/xchat/xchat-1.8.8.ebuild
new file mode 100644
index 000000000000..8debca643817
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.8.ebuild
@@ -0,0 +1,61 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.8.ebuild,v 1.1 2002/03/10 11:24:23 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is an IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ if [ "`use python`" ]
+ then
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' configure.orig > configure
+ fi
+}
+
+src_compile() {
+
+ local myopts myflags
+ use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config`"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+ use mmx && myopts="$myopts --enable-mmx"
+
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING ChangeLog README
+}