summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-16 13:46:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-16 13:46:11 +0000
commit0a4bd4f69d137d6442704b360ec806fd1e8b8e73 (patch)
tree429fd563d2ecf5eb1715a2b07726aeed6be4b828 /net-irc
parentremoved older ebuilds (diff)
downloadgentoo-2-0a4bd4f69d137d6442704b360ec806fd1e8b8e73.tar.gz
gentoo-2-0a4bd4f69d137d6442704b360ec806fd1e8b8e73.tar.bz2
gentoo-2-0a4bd4f69d137d6442704b360ec806fd1e8b8e73.zip
Quick version bump and ebuild cleanup
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bitchx/ChangeLog10
-rw-r--r--net-irc/bitchx/bitchx-1.0.19.ebuild112
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.191
3 files changed, 122 insertions, 1 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index b3852c78fda0..e4a065f9d382 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/bitchx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.3 2002/04/07 10:58:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.4 2002/04/16 13:46:11 seemant Exp $
+
+*bitchx-1.0.19 (16 Apr 2002)
+
+ 16 Apr 2002; Seemant Kulleen <seemant@gentoo.org> bitchx-1.0.19.ebuild,
+ files/digest-bitchx-1.0.19
+
+ Quick version bump, and ebuild clean up
+
25 Feb 2002; Geert Bevin <gbevin@gentoo.org> bitchx-1.0.18-r5.ebuild,
files/bitchx-1.0.18-dupver.patch :
diff --git a/net-irc/bitchx/bitchx-1.0.19.ebuild b/net-irc/bitchx/bitchx-1.0.19.ebuild
new file mode 100644
index 000000000000..2d2922e3f5fb
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.19.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19.ebuild,v 1.1 2002/04/16 13:46:11 seemant Exp $
+
+MY_P=ircii-pana-${PV/.0./.0c}
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.bitchx.com/"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ xmms? ( media-sound/xmms )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( sys-libs/ncurses )
+ esd? ( >=media-sound/esound-0.2.5
+ >=media-libs/audiofile-0.1.5 )
+ gtk? ( >=x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1 )"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+# patch -p1 < ${FILESDIR}/${P}-dupver.patch || die
+#}
+
+src_compile() {
+
+ local myconf
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use esd && use gtk \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ use gtk \
+ || myconf="${myconf} --without-gtk"
+
+ use ipv6 \
+ && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ #not tested
+# use ncurses \
+# && myconf="${myconf} --without-tgetent" \
+# || myconf="${myconf} --with-tgetent"
+
+ use socks5 \
+ && myconf="${myconf} --with-socks=5" \
+ || myconf="${myconf} --without-socks"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cdrom \
+ --with-plugins \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${D}/usr/bin
+
+ use gnome && ( \
+ exeinto /usr/bin
+ newexe ${S}/source/BitchX BitchX-1.0c18
+ dosym gtkBitchX-1.0c18 /usr/bin/gtkBitchX
+ )
+
+ dosym BitchX-1.0c18 /usr/bin/BitchX
+
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ cd ${S}
+ dodoc Changelog README* IPv6-support
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ dohtml *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ cp acro/README acro/README.acro
+ dodoc acro/README.acro
+ cp arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ cp blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ cp qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.19 b/net-irc/bitchx/files/digest-bitchx-1.0.19
new file mode 100644
index 000000000000..733d621134c6
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.19
@@ -0,0 +1 @@
+MD5 79431ff0880e7317049045981fac8adc ircii-pana-1.0c19.tar.gz 2533621