summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-24 20:33:09 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-24 20:33:09 +0000
commit9689f3ab6cde417bb9b3ab6853c14d316fb332ec (patch)
treebcb08e0f1a81d996dc645aace03f2e68e79ee1a7 /net-irc/znc
parentVersion bump (diff)
downloadgentoo-2-9689f3ab6cde417bb9b3ab6853c14d316fb332ec.tar.gz
gentoo-2-9689f3ab6cde417bb9b3ab6853c14d316fb332ec.tar.bz2
gentoo-2-9689f3ab6cde417bb9b3ab6853c14d316fb332ec.zip
Version bump, x86 stable
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog10
-rw-r--r--net-irc/znc/znc-0.060.ebuild6
-rw-r--r--net-irc/znc/znc-0.062.ebuild42
3 files changed, 53 insertions, 5 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index dff80066f925..e582b628f76b 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/znc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.17 2008/09/24 18:01:50 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.18 2009/01/24 20:33:09 armin76 Exp $
+
+*znc-0.062 (24 Jan 2009)
+
+ 24 Jan 2009; Raúl Porcel <armin76@gentoo.org> znc-0.060.ebuild,
+ +znc-0.062.ebuild:
+ Version bump, x86 stable
*znc-0.060 (24 Sep 2008)
diff --git a/net-irc/znc/znc-0.060.ebuild b/net-irc/znc/znc-0.060.ebuild
index 6aa5b44d2f4a..39c6e00722a4 100644
--- a/net-irc/znc/znc-0.060.ebuild
+++ b/net-irc/znc/znc-0.060.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.060.ebuild,v 1.1 2008/09/24 18:01:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.060.ebuild,v 1.2 2009/01/24 20:33:09 armin76 Exp $
inherit autotools
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
IUSE="debug ipv6 nomodules perl ssl"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
diff --git a/net-irc/znc/znc-0.062.ebuild b/net-irc/znc/znc-0.062.ebuild
new file mode 100644
index 000000000000..efaac26694a8
--- /dev/null
+++ b/net-irc/znc/znc-0.062.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.062.ebuild,v 1.1 2009/01/24 20:33:09 armin76 Exp $
+
+inherit autotools
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6 nomodules perl ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
+ perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable !nomodules modules) \
+ $(use_enable perl) \
+ $(use_enable ssl openssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS znc.conf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog
+}