summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-12 05:17:54 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-12 05:17:54 +0000
commite72ba935481872dc6dfe20ba094268871965273f (patch)
treed135e7e92fcdbf968e504df38b2a6f0edf079389 /net-irc/xchatosd
parentSupport for four-digit control data. (diff)
downloadgentoo-2-e72ba935481872dc6dfe20ba094268871965273f.tar.gz
gentoo-2-e72ba935481872dc6dfe20ba094268871965273f.tar.bz2
gentoo-2-e72ba935481872dc6dfe20ba094268871965273f.zip
Fix building w/ gcc-4.3 for bug #251449. Thanks to Gene Seto for the
patch. (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/xchatosd')
-rw-r--r--net-irc/xchatosd/ChangeLog9
-rw-r--r--net-irc/xchatosd/files/xchatosd-5.19-gcc43.patch43
-rw-r--r--net-irc/xchatosd/xchatosd-5.19.ebuild5
3 files changed, 53 insertions, 4 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index c549ee378c95..668513c051b6 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchatosd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.21 2007/02/23 11:10:53 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.22 2009/02/12 05:17:54 dirtyepic Exp $
+
+ 12 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/xchatosd-5.19-gcc43.patch, xchatosd-5.19.ebuild:
+ Fix building w/ gcc-4.3 for bug #251449. Thanks to Gene Seto for the
+ patch.
23 Feb 2007; Raúl Porcel <armin76@gentoo.org> xchatosd-5.19.ebuild:
Remove ROOT, bug 168039
diff --git a/net-irc/xchatosd/files/xchatosd-5.19-gcc43.patch b/net-irc/xchatosd/files/xchatosd-5.19-gcc43.patch
new file mode 100644
index 000000000000..35185c6967a9
--- /dev/null
+++ b/net-irc/xchatosd/files/xchatosd-5.19-gcc43.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/show_bug.cgi?id=251449
+
+--- xchatosd-5.19-orig/xchatosd_conf.cpp
++++ xchatosd-5.19/xchatosd_conf.cpp
+@@ -1,4 +1,6 @@
+ #include "xchatosd_conf.h"
++#include <cstdlib>
++#include <cstring>
+
+ XOsdConf::XOsdConf()
+ {
+--- xchatosd-5.19-orig/xchatosd.cpp
++++ xchatosd-5.19/xchatosd.cpp
+@@ -3,8 +3,7 @@
+ #include <fstream>
+ #include <iostream>
+ #include <xosd.h>
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstring>
+ #include <langinfo.h>
+ #include "xchatosd.h"
+ #include "xchatosd_lang.h"
+@@ -22,7 +21,7 @@ using namespace std;
+ static xchat_plugin *ph;
+ static XOsd *osd = NULL;
+ static XOsdConf config;
+-static char *codepage;
++static char const *codepage;
+ #ifdef ICONV_LIB
+ static iconv_t iconv_desc = (iconv_t) (-1);
+ #endif
+@@ -445,8 +444,8 @@ static int osd_notify_cb(char *word[], c
+
+ extern "C" { int
+ xchat_plugin_init(xchat_plugin * plugin_handle,
+- char **plugin_name,
+- char **plugin_desc, char **plugin_version, char *arg)
++ char const **plugin_name,
++ char const **plugin_desc, char const **plugin_version, char *arg)
+ {
+ ph = plugin_handle;
+ XOSDconfRead();
diff --git a/net-irc/xchatosd/xchatosd-5.19.ebuild b/net-irc/xchatosd/xchatosd-5.19.ebuild
index 3ca2e771c7de..71a3476d1584 100644
--- a/net-irc/xchatosd/xchatosd-5.19.ebuild
+++ b/net-irc/xchatosd/xchatosd-5.19.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.19.ebuild,v 1.6 2007/02/23 11:10:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.19.ebuild,v 1.7 2009/02/12 05:17:54 dirtyepic Exp $
inherit toolchain-funcs flag-o-matic
@@ -24,6 +24,7 @@ src_unpack() {
einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"
cp -f /usr/include/xchat/xchat-plugin.h "${S}"/xchat-plugin.h
epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {