summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-02-19 23:40:57 +0000
committerSven Wegener <swegener@gentoo.org>2005-02-19 23:40:57 +0000
commit535a561a159c472723abfa1d6d1b7570c8c9dc41 (patch)
treea27db81c9d1e8e9f549b6890bc445903d2aa34e7 /net-irc/xchatosd
parentNew ebuild by me .. thanks to cYmen in #gentoo-laptop for testing. (diff)
downloadgentoo-2-535a561a159c472723abfa1d6d1b7570c8c9dc41.tar.gz
gentoo-2-535a561a159c472723abfa1d6d1b7570c8c9dc41.tar.bz2
gentoo-2-535a561a159c472723abfa1d6d1b7570c8c9dc41.zip
Added a patch that fixes wrong return value checking. Closes bug #82546.
(Portage version: 2.0.51.16)
Diffstat (limited to 'net-irc/xchatosd')
-rw-r--r--net-irc/xchatosd/ChangeLog9
-rw-r--r--net-irc/xchatosd/files/5.17-return-values.patch38
-rw-r--r--net-irc/xchatosd/files/digest-xchatosd-5.17-r1 (renamed from net-irc/xchatosd/files/digest-xchatosd-5.17)0
-rw-r--r--net-irc/xchatosd/xchatosd-5.17-r1.ebuild (renamed from net-irc/xchatosd/xchatosd-5.17.ebuild)3
4 files changed, 48 insertions, 2 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index 4b677a7946b2..928c6eefcff8 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchatosd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.8 2005/02/17 02:54:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.9 2005/02/19 23:40:57 swegener Exp $
+
+*xchatosd-5.17-r1 (20 Feb 2005)
+
+ 20 Feb 2005; Sven Wegener <swegener@gentoo.org>
+ +files/5.17-return-values.patch, +xchatosd-5.17-r1.ebuild,
+ -xchatosd-5.17.ebuild:
+ Added a patch that fixes wrong return value checking. Closes bug #82546.
*xchatosd-5.17 (17 Feb 2005)
diff --git a/net-irc/xchatosd/files/5.17-return-values.patch b/net-irc/xchatosd/files/5.17-return-values.patch
new file mode 100644
index 000000000000..a45de146bb8a
--- /dev/null
+++ b/net-irc/xchatosd/files/5.17-return-values.patch
@@ -0,0 +1,38 @@
+--- xchatosd.cpp.orig 2005-02-20 00:35:28.056851489 +0100
++++ xchatosd.cpp 2005-02-20 00:36:19.240761787 +0100
+@@ -79,16 +79,25 @@
+ return -1;
+ }
+ int status = 0;
+- status += osd->setPos(config.getValue("pos"));
+- status += osd->setVOffset(config.getiValue("voffset"));
+- status += osd->setHOffset(config.getiValue("hoffset"));
+- status += osd->setAlign(config.getValue("align"));
+- status += osd->setSOffset(config.getiValue("shadow"));
+- status += osd->setTimeout(config.getiValue("timeout"));
+- status += osd->setFont(config.getValue("font"));
+- status += osd->setColor(config.getValue("color"));
+- status += osd->display(MSG_Hello);
+- return status;
++ status = osd->setPos(config.getValue("pos"));
++ if (-1 == status) return -1;
++ status = osd->setVOffset(config.getiValue("voffset"));
++ if (-1 == status) return -1;
++ status = osd->setHOffset(config.getiValue("hoffset"));
++ if (-1 == status) return -1;
++ status = osd->setAlign(config.getValue("align"));
++ if (-1 == status) return -1;
++ status = osd->setSOffset(config.getiValue("shadow"));
++ if (-1 == status) return -1;
++ status = osd->setTimeout(config.getiValue("timeout"));
++ if (-1 == status) return -1;
++ status = osd->setFont(config.getValue("font"));
++ if (-1 == status) return -1;
++ status = osd->setColor(config.getValue("color"));
++ if (-1 == status) return -1;
++ status = osd->display(MSG_Hello);
++ if (-1 == status) return -1;
++ return 0;
+ }
+
+ #ifdef ICONV_LIB
diff --git a/net-irc/xchatosd/files/digest-xchatosd-5.17 b/net-irc/xchatosd/files/digest-xchatosd-5.17-r1
index 24ccca38e0fd..24ccca38e0fd 100644
--- a/net-irc/xchatosd/files/digest-xchatosd-5.17
+++ b/net-irc/xchatosd/files/digest-xchatosd-5.17-r1
diff --git a/net-irc/xchatosd/xchatosd-5.17.ebuild b/net-irc/xchatosd/xchatosd-5.17-r1.ebuild
index bb3fbc0150a4..9f874d1820b0 100644
--- a/net-irc/xchatosd/xchatosd-5.17.ebuild
+++ b/net-irc/xchatosd/xchatosd-5.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.17.ebuild,v 1.1 2005/02/17 02:54:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.17-r1.ebuild,v 1.1 2005/02/19 23:40:57 swegener Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -22,6 +22,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-iconv-fix.patch
+ epatch ${FILESDIR}/${PV}-return-values.patch
# We have our own include file in /usr/include/xchat
einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"