summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-08-24 22:43:23 +0000
committerSven Wegener <swegener@gentoo.org>2004-08-24 22:43:23 +0000
commit7a000a8a38953eeee0d876c8e053d5208190b147 (patch)
treea3111f6aa231f1a80502e42d0c61453ea2d4f49e /net-irc/xchat-systray
parentw00t, 142 bytes reduction with: optipng -zc9 -zm5 -zs0 -f0 screenshot.png ;) ... (diff)
downloadgentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.tar.gz
gentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.tar.bz2
gentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.zip
Revision bump for a patch that fixes segfaults on executing browser, mail client and multimedia player. Closes bug #61521.
Diffstat (limited to 'net-irc/xchat-systray')
-rw-r--r--net-irc/xchat-systray/ChangeLog10
-rw-r--r--net-irc/xchat-systray/files/2.4.5-segfault-fix.patch27
-rw-r--r--net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r1 (renamed from net-irc/xchat-systray/files/digest-xchat-systray-2.4.5)0
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild (renamed from net-irc/xchat-systray/xchat-systray-2.4.5.ebuild)11
4 files changed, 45 insertions, 3 deletions
diff --git a/net-irc/xchat-systray/ChangeLog b/net-irc/xchat-systray/ChangeLog
index fc1b12aa40bb..7ff11fba3042 100644
--- a/net-irc/xchat-systray/ChangeLog
+++ b/net-irc/xchat-systray/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/xchat-systray
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.13 2004/08/24 02:12:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.14 2004/08/24 22:43:23 swegener Exp $
+
+*xchat-systray-2.4.5-r1 (25 Aug 2004)
+
+ 25 Aug 2004; Sven Wegener <swegener@gentoo.org>
+ +files/2.4.5-segfault-fix.patch, +xchat-systray-2.4.5-r1.ebuild,
+ -xchat-systray-2.4.5.ebuild:
+ Revision bump for a patch that fixes segfaults on executing browser, mail
+ client and multimedia player. Closes bug #61521.
24 Aug 2004; Sven Wegener <swegener@gentoo.org> xchat-systray-2.4.5.ebuild:
Stable on x86.
diff --git a/net-irc/xchat-systray/files/2.4.5-segfault-fix.patch b/net-irc/xchat-systray/files/2.4.5-segfault-fix.patch
new file mode 100644
index 000000000000..c824f4a1ed02
--- /dev/null
+++ b/net-irc/xchat-systray/files/2.4.5-segfault-fix.patch
@@ -0,0 +1,27 @@
+diff -Nur xchat-systray-integration-2.4.5/src/menu.c xchat-systray-integration-2.4.5-segfault-fix/src/menu.c
+--- xchat-systray-integration-2.4.5/src/menu.c 2004-04-30 14:38:10.000000000 +0200
++++ xchat-systray-integration-2.4.5-segfault-fix/src/menu.c 2004-08-25 00:34:04.321825360 +0200
+@@ -10,7 +10,6 @@
+ char command[156]="exec ";
+ strcat(command, bpath);
+ xchat_command( ph, command );
+- g_free(command);
+
+ }
+
+@@ -20,7 +19,6 @@
+ char command[156]="exec ";
+ strcat(command, epath);
+ xchat_command( ph, command );
+- g_free(command);
+
+ }
+
+@@ -30,7 +28,6 @@
+ char command[156]="exec ";
+ strcat(command, ppath);
+ xchat_command( ph, command );
+- g_free(command);
+
+ }
+
diff --git a/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5 b/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r1
index 7f98a7624e3c..7f98a7624e3c 100644
--- a/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5
+++ b/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r1
diff --git a/net-irc/xchat-systray/xchat-systray-2.4.5.ebuild b/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild
index 4ffeb0293c58..89db64a3f929 100644
--- a/net-irc/xchat-systray/xchat-systray-2.4.5.ebuild
+++ b/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.5.ebuild,v 1.4 2004/08/24 02:12:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild,v 1.1 2004/08/24 22:43:23 swegener Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
MY_P=${PN}-integration-${PV}
@@ -26,6 +26,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-segfault-fix.patch
+}
+
src_compile() {
append-flags -fPIC
emake -j1 CFLAGS="${CFLAGS}" || die "Compile failed"