summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-22 10:09:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-22 10:09:13 +0000
commit588ee7367c8c8c18ceae6ba10ccc7499c02315db (patch)
tree78f45c6b5bf4a5fb39fb1bb1aa16ec3e52892857 /net-irc/weechat
parentCheck if the jruby is also in IUSE before checking if it is enabled. (diff)
downloadgentoo-2-588ee7367c8c8c18ceae6ba10ccc7499c02315db.tar.gz
gentoo-2-588ee7367c8c8c18ceae6ba10ccc7499c02315db.tar.bz2
gentoo-2-588ee7367c8c8c18ceae6ba10ccc7499c02315db.zip
Version bump to latest release.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/ChangeLog8
-rw-r--r--net-irc/weechat/weechat-0.3.6.ebuild104
-rw-r--r--net-irc/weechat/weechat-9999.ebuild14
3 files changed, 120 insertions, 6 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index be9c892be188..df11fb8184f6 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/weechat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.95 2011/09/19 02:05:50 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.96 2011/10/22 10:09:12 scarabeus Exp $
+
+*weechat-0.3.6 (22 Oct 2011)
+
+ 22 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +weechat-0.3.6.ebuild,
+ weechat-9999.ebuild:
+ Version bump to latest release.
19 Sep 2011; Nathan Phillip Brink <binki@gentoo.org> weechat-0.3.5.ebuild,
weechat-9999.ebuild:
diff --git a/net-irc/weechat/weechat-0.3.6.ebuild b/net-irc/weechat/weechat-0.3.6.ebuild
new file mode 100644
index 000000000000..f3cd4109434f
--- /dev/null
+++ b/net-irc/weechat/weechat-0.3.6.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.6.ebuild,v 1.1 2011/10/22 10:09:13 scarabeus Exp $
+
+EAPI=3
+
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL="yes"
+
+PYTHON_DEPEND="python? 2"
+
+EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+inherit python multilib ruby-ng cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Portable and multi-interface IRC client."
+HOMEPAGE="http://weechat.org/"
+[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-linux ~amd64-linux"
+fi
+
+NETWORKS="+irc"
+PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
+#INTERFACES="+ncurses gtk"
+SCRIPT_LANGS="lua +perl +python ruby tcl"
+IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} +crypt doc nls +ssl"
+
+RDEPEND="
+ sys-libs/ncurses
+ charset? ( virtual/libiconv )
+ lua? ( dev-lang/lua[deprecated] )
+ perl? ( dev-lang/perl )
+ ruby? ( $(ruby_implementations_depend) )
+ ssl? ( net-libs/gnutls )
+ spell? ( app-text/aspell )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+"
+# ncurses? ( sys-libs/ncurses )
+# gtk? ( x11-libs/gtk+:2 )
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+#REQUIRED_USE=" || ( ncurses gtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ ruby-ng_pkg_setup
+}
+
+src_prepare() {
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+}
+
+# alias, rmodifier, xfer
+src_configure() {
+ # $(cmake-utils_use_enable gtk)
+ # $(cmake-utils_use_enable ncurses)
+ mycmakeargs=(
+ "-DENABLE_NCURSES=ON"
+ "-DENABLE_LARGEFILE=ON"
+ "-DENABLE_DEMO=OFF"
+ "-DENABLE_GTK=OFF"
+ $(cmake-utils_use_enable nls)
+ $(cmake-utils_use_enable crypt GCRYPT)
+ $(cmake-utils_use_enable spell ASPELL)
+ $(cmake-utils_use_enable charset)
+ $(cmake-utils_use_enable fifo)
+ $(cmake-utils_use_enable irc)
+ $(cmake-utils_use_enable logger)
+ $(cmake-utils_use_enable relay)
+ $(cmake-utils_use_enable scripts)
+ $(cmake-utils_use_enable perl)
+ $(cmake-utils_use_enable python)
+ $(cmake-utils_use_enable ruby)
+ $(cmake-utils_use_enable lua)
+ $(cmake-utils_use_enable tcl)
+ $(cmake-utils_use_enable doc)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use scripts && use python; then
+ elog "You can use handy script from upstream to manage your scripts:"
+ elog " http://www.weechat.org/scripts/source/stable/weeget.py/"
+ elog "This thing downloads and updates all other scripts for you."
+ fi
+}
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 97194709bf74..bf6eda574090 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.10 2011/09/19 02:05:51 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.11 2011/10/22 10:09:13 scarabeus Exp $
EAPI=3
@@ -27,20 +27,21 @@ fi
NETWORKS="+irc"
PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
-INTERFACES="+ncurses" # gtk"
+#INTERFACES="+ncurses gtk"
SCRIPT_LANGS="lua +perl +python ruby tcl"
IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} +crypt doc nls +ssl"
RDEPEND="
+ sys-libs/ncurses
charset? ( virtual/libiconv )
lua? ( dev-lang/lua[deprecated] )
- ncurses? ( sys-libs/ncurses )
perl? ( dev-lang/perl )
ruby? ( $(ruby_implementations_depend) )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15 )
"
+# ncurses? ( sys-libs/ncurses )
# gtk? ( x11-libs/gtk+:2 )
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.15 )
@@ -48,10 +49,11 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
-#REQUIRED_USE=" || ( ncurses )" # || ( ncurses gtk )
+#REQUIRED_USE=" || ( ncurses gtk )"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
ruby-ng_pkg_setup
}
@@ -66,11 +68,13 @@ src_prepare() {
# alias, rmodifier, xfer
src_configure() {
+ # $(cmake-utils_use_enable gtk)
+ # $(cmake-utils_use_enable ncurses)
mycmakeargs=(
+ "-DENABLE_NCURSES=ON"
"-DENABLE_LARGEFILE=ON"
"-DENABLE_DEMO=OFF"
"-DENABLE_GTK=OFF"
- $(cmake-utils_use_enable ncurses)
$(cmake-utils_use_enable nls)
$(cmake-utils_use_enable crypt GCRYPT)
$(cmake-utils_use_enable spell ASPELL)