summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2007-12-09 11:22:45 +0000
committerDawid Węgliński <cla@gentoo.org>2007-12-09 11:22:45 +0000
commitdfd83be5de7afa281c41576c80a8fbdfe3d6a437 (patch)
tree2c3cf4f066099b473f073c0684fa1d300a5c8ad2 /net-irc/unrealircd
parentVersion bump, ebuild cleanups. (diff)
downloadgentoo-2-dfd83be5de7afa281c41576c80a8fbdfe3d6a437.tar.gz
gentoo-2-dfd83be5de7afa281c41576c80a8fbdfe3d6a437.tar.bz2
gentoo-2-dfd83be5de7afa281c41576c80a8fbdfe3d6a437.zip
Move docert call from src_install() to pkg_postinst() for bug #201682
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-irc/unrealircd')
-rw-r--r--net-irc/unrealircd/files/digest-unrealircd-3.2.7-r13
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.7-r1.ebuild140
2 files changed, 143 insertions, 0 deletions
diff --git a/net-irc/unrealircd/files/digest-unrealircd-3.2.7-r1 b/net-irc/unrealircd/files/digest-unrealircd-3.2.7-r1
new file mode 100644
index 000000000000..1f65301c0985
--- /dev/null
+++ b/net-irc/unrealircd/files/digest-unrealircd-3.2.7-r1
@@ -0,0 +1,3 @@
+MD5 39d3a58f4ad7b5407b6e2093f666b20c Unreal3.2.7.tar.gz 2801622
+RMD160 49e00dbe4fdda672b20be16ceb116971f514d62b Unreal3.2.7.tar.gz 2801622
+SHA256 f80078da5e9efa1487ab22957aeb295f94c2d4efd144f825f1efc5ee8df72d46 Unreal3.2.7.tar.gz 2801622
diff --git a/net-irc/unrealircd/unrealircd-3.2.7-r1.ebuild b/net-irc/unrealircd/unrealircd-3.2.7-r1.ebuild
new file mode 100644
index 000000000000..d716768ff90c
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.2.7-r1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.7-r1.ebuild,v 1.1 2007/12/09 11:22:45 cla Exp $
+
+inherit eutils ssl-cert versionator multilib
+
+MY_P=Unreal${PV}
+
+DESCRIPTION="aimed to be an advanced (not easy) IRCd"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://unreal.brueggisite.de/${MY_P}.tar.gz
+ http://www.blurryfox.com/unreal/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="hub ipv6 ssl zlib curl prefixaq showlistmodes"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/Unreal${PV}"
+
+pkg_setup() {
+ if use curl && ( ! built_with_use net-misc/curl ares || built_with_use net-misc/curl ipv6 )
+ then
+ eerror "You need net-misc/curl compiled with the ares USE flag to be able to use"
+ eerror "net-irc/unrealircd with the curl USE flag. Please note that ares support"
+ eerror "for net-misc/curl is incompatible with the ipv6 USE flag."
+ die "need net-misc/curl with ares support"
+ fi
+
+ enewuser unrealircd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
+ -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
+ -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
+ -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
+ include/config.h
+}
+
+src_compile() {
+ local myconf=""
+ use curl && myconf="${myconf} --enable-libcurl=/usr"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use zlib && myconf="${myconf} --enable-ziplinks"
+ use hub && myconf="${myconf} --enable-hub"
+ use ssl && myconf="${myconf} --enable-ssl"
+ use prefixaq && myconf="${myconf} --enable-prefixaq"
+ use showlistmodes && myconf="${myconf} --with-showlistmodes"
+
+ econf \
+ --with-listen=5 \
+ --with-dpath="${D}"/etc/unrealircd \
+ --with-spath=/usr/bin/unrealircd \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-hostname=$(hostname -f) \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --enable-dynamic-linking \
+ ${myconf} \
+ || die "econf failed"
+
+ sed -i \
+ -e "s:${D}::" \
+ include/setup.h \
+ ircdcron/ircdchk
+
+ emake MAKE=make IRCDDIR=/etc/unrealircd || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/{lib,log,run}/unrealircd
+
+ newbin src/ircd unrealircd
+
+ exeinto /usr/$(get_libdir)/unrealircd/modules
+ doexe src/modules/*.so
+
+ dodir /etc/unrealircd
+ dosym /var/lib/unrealircd /etc/unrealircd/tmp
+
+ insinto /etc/unrealircd
+ doins {badwords.*,help,spamfilter,dccallow}.conf
+ newins doc/example.conf unrealircd.conf
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf
+ insinto /etc/unrealircd/networks
+ doins networks/*.network
+
+ sed -i \
+ -e s:src/modules:/usr/$(get_libdir)/unrealircd/modules: \
+ -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
+ "${D}"/etc/unrealircd/unrealircd.conf
+
+ dodoc \
+ Changes Donation Unreal.nfo networks/makenet \
+ ircdcron/{ircd.cron,ircdchk} \
+ || die "dodoc failed"
+ dohtml doc/*.html
+
+ newinitd "${FILESDIR}"/unrealircd.rc unrealircd
+ newconfd "${FILESDIR}"/unrealircd.confd unrealircd
+
+ fperms 700 /etc/unrealircd
+ chown -R unrealircd "${D}"/{etc,var/{lib,log,run}}/unrealircd
+}
+
+pkg_postinst() {
+ # Move docert call from scr_install() to install_cert in pkg_postinst for
+ # bug #201682
+ use ssl && \
+ if [[ ! -f "${ROOT}"/etc/unrealircd/server.cert.key ]]; then
+ install_cert /etc/unrealircd/server.cert
+ dosym server.cert.key /etc/unrealircd/server.key.pem
+ fi
+
+ elog
+ elog "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ elog
+ elog "You can find example cron scripts here:"
+ elog " /usr/share/doc/${PF}/ircd.cron.gz"
+ elog " /usr/share/doc/${PF}/ircdchk.gz"
+ elog
+ elog "You can also use /etc/init.d/unrealircd to start at boot"
+ elog
+}