summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-06-30 11:43:58 +0000
committerPacho Ramos <pacho@gentoo.org>2012-06-30 11:43:58 +0000
commit5fb837ae33a4b98eaa2267e878096ecae7739e37 (patch)
treedfe13a6de36dc82ad9f111f3051f9fb2c70b3a1c /net-irc/smuxi
parentFix elementary Prefix error using ED for DESTDIR in make install. (diff)
downloadgentoo-2-5fb837ae33a4b98eaa2267e878096ecae7739e37.tar.gz
gentoo-2-5fb837ae33a4b98eaa2267e878096ecae7739e37.tar.bz2
gentoo-2-5fb837ae33a4b98eaa2267e878096ecae7739e37.zip
Version bump.
(Portage version: 2.1.11.3/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/smuxi')
-rw-r--r--net-irc/smuxi/ChangeLog8
-rw-r--r--net-irc/smuxi/smuxi-0.8.9.2.ebuild47
2 files changed, 53 insertions, 2 deletions
diff --git a/net-irc/smuxi/ChangeLog b/net-irc/smuxi/ChangeLog
index c91d209b83d5..211c6dea5476 100644
--- a/net-irc/smuxi/ChangeLog
+++ b/net-irc/smuxi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/smuxi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.20 2012/06/16 12:09:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.21 2012/06/30 11:43:58 pacho Exp $
+
+*smuxi-0.8.9.2 (30 Jun 2012)
+
+ 30 Jun 2012; Pacho Ramos <pacho@gentoo.org> +smuxi-0.8.9.2.ebuild:
+ Version bump.
16 Jun 2012; Agostino Sarubbo <ago@gentoo.org> -smuxi-0.8.ebuild:
Remove old as requested by Pacho Ramos, <pacho@gentoo.org>
@@ -91,4 +96,3 @@
31 Jan 2009; Peter Alfredsen <loki_val@gentoo.org>
+files/smuxi-0.6.3-mono-2.2.patch, +metadata.xml, +smuxi-0.6.3.ebuild:
Initial commit. Ebuild by me.
-
diff --git a/net-irc/smuxi/smuxi-0.8.9.2.ebuild b/net-irc/smuxi/smuxi-0.8.9.2.ebuild
new file mode 100644
index 000000000000..263c534ab01f
--- /dev/null
+++ b/net-irc/smuxi/smuxi-0.8.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/smuxi-0.8.9.2.ebuild,v 1.1 2012/06/30 11:43:58 pacho Exp $
+
+EAPI="4"
+
+inherit base mono eutils
+
+DESCRIPTION="A flexible, irssi-like and user-friendly IRC client for the Gnome Desktop."
+HOMEPAGE="http://www.smuxi.org/main/"
+SRC_URI="http://www.smuxi.org/jaws/data/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug gnome libnotify"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/smartirc4net-0.4.5.1
+ >=dev-dotnet/nini-1.1.0-r2
+ >=dev-dotnet/log4net-1.2.10-r2
+ dbus? ( dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/ndesk-dbus
+ dev-dotnet/ndesk-dbus-glib )
+ gnome? ( >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gconf-sharp-2.12
+ >=dev-dotnet/glade-sharp-2.12
+ >=dev-dotnet/glib-sharp-2.12 )
+ libnotify? ( dev-dotnet/notify-sharp )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+
+DOCS="FEATURES TODO README"
+
+src_configure() {
+# Our dev-dotnet/db4o is completely unmaintained
+ econf --enable-engine-irc \
+ --without-indicate \
+ --with-vendor-package-version="Gentoo ${PV}" \
+ --with-db4o=included \
+ $(use_enable debug) \
+ $(use_enable gnome frontend-gnome) \
+ $(use_with libnotify notify)
+}