summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2007-09-05 12:54:37 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2007-09-05 12:54:37 +0000
commit89221ebe5f20e0fe0994eb84019fdb4a0085e17d (patch)
treeb118f52b86c9cca9496fc592a4c76b9f2871b036 /net-irc/konversation
parentVersion bump from project overlay (diff)
downloadgentoo-2-89221ebe5f20e0fe0994eb84019fdb4a0085e17d.tar.gz
gentoo-2-89221ebe5f20e0fe0994eb84019fdb4a0085e17d.tar.bz2
gentoo-2-89221ebe5f20e0fe0994eb84019fdb4a0085e17d.zip
Adding patch wrt security bug #189255
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-irc/konversation')
-rw-r--r--net-irc/konversation/ChangeLog9
-rw-r--r--net-irc/konversation/files/digest-konversation-1.0.1-r33
-rw-r--r--net-irc/konversation/files/konversation-1.0.1-media-script-vulnerability.patch41
-rw-r--r--net-irc/konversation/konversation-1.0.1-r3.ebuild37
4 files changed, 89 insertions, 1 deletions
diff --git a/net-irc/konversation/ChangeLog b/net-irc/konversation/ChangeLog
index d5cc7eeba0b7..0dace6de8a45 100644
--- a/net-irc/konversation/ChangeLog
+++ b/net-irc/konversation/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/konversation
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/konversation/ChangeLog,v 1.55 2007/08/16 16:20:19 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/konversation/ChangeLog,v 1.56 2007/09/05 12:54:37 keytoaster Exp $
+
+*konversation-1.0.1-r3 (05 Sep 2007)
+
+ 05 Sep 2007; Tobias Heinlein <keytoaster@gentoo.org>
+ +files/konversation-1.0.1-media-script-vulnerability.patch,
+ +konversation-1.0.1-r3.ebuild:
+ Adding patch wrt security bug #189255
*konversation-1.0.1-r2 (16 Aug 2007)
diff --git a/net-irc/konversation/files/digest-konversation-1.0.1-r3 b/net-irc/konversation/files/digest-konversation-1.0.1-r3
new file mode 100644
index 000000000000..f5304937b259
--- /dev/null
+++ b/net-irc/konversation/files/digest-konversation-1.0.1-r3
@@ -0,0 +1,3 @@
+MD5 60c2c5f94d4a916055db09728304b19f konversation-1.0.1.tar.bz2 5848563
+RMD160 1cf79a87f451aa2718560f00ddf987b68938310a konversation-1.0.1.tar.bz2 5848563
+SHA256 8be736289c52c21fe5ada7dd153767abd5155424a510ab9781b9d2f585cc00fd konversation-1.0.1.tar.bz2 5848563
diff --git a/net-irc/konversation/files/konversation-1.0.1-media-script-vulnerability.patch b/net-irc/konversation/files/konversation-1.0.1-media-script-vulnerability.patch
new file mode 100644
index 000000000000..7c7bd32cf6e3
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.0.1-media-script-vulnerability.patch
@@ -0,0 +1,41 @@
+diff -aur konversation-1.0.1/konversation/src/channel.cpp konversation-1.0.1-fixed/konversation/src/channel.cpp
+--- konversation-1.0.1/konversation/src/channel.cpp 2006-10-06 18:43:29.000000000 +0200
++++ konversation-1.0.1-fixed/konversation/src/channel.cpp 2007-09-05 01:10:52.000000000 +0200
+@@ -890,7 +890,7 @@
+ }
+
+ // Send all strings, one after another
+- QStringList outList=QStringList::split('\n',outputAll);
++ QStringList outList=QStringList::split(QRegExp("[\r\n]+"),outputAll);
+ for(unsigned int index=0;index<outList.count();index++)
+ {
+ QString output(outList[index]);
+diff -aur konversation-1.0.1/konversation/src/konvdcop.cpp konversation-1.0.1-fixed/konversation/src/konvdcop.cpp
+--- konversation-1.0.1/konversation/src/konvdcop.cpp 2006-10-06 18:43:29.000000000 +0200
++++ konversation-1.0.1-fixed/konversation/src/konvdcop.cpp 2007-09-05 01:11:08.000000000 +0200
+@@ -82,15 +82,23 @@
+ emit dcopMultiServerRaw("me " + message);
+ }
+
+-void KonvDCOP::say(const QString& server,const QString& target,const QString& command)
++void KonvDCOP::say(const QString& _server,const QString& _target,const QString& _command)
+ {
++ //Sadly, copy on write doesn't exist with QString::replace
++ QString server(_server), target(_target), command(_command);
++
+ // TODO: this just masks a greater problem - Server::addQuery will return a query for '' --argonel
+ // TODO: other DCOP calls need argument checking too --argonel
+ if (server.isEmpty() || target.isEmpty() || command.isEmpty())
+ kdDebug() << "KonvDCOP::say() requires 3 arguments." << endl;
+ else
+ {
+- kdDebug() << "KonvDCOP::say()" << endl;
++ command.replace('\n',"\\n");
++ command.replace('\r',"\\r");
++ target.remove('\n');
++ target.remove('\r');
++ server.remove('\n');
++ server.remove('\r');
+ // Act as if the user typed it
+ emit dcopSay(server,target,command);
+ }
diff --git a/net-irc/konversation/konversation-1.0.1-r3.ebuild b/net-irc/konversation/konversation-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..4f4b00820fdf
--- /dev/null
+++ b/net-irc/konversation/konversation-1.0.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/konversation/konversation-1.0.1-r3.ebuild,v 1.1 2007/09/05 12:54:37 keytoaster Exp $
+
+LANGS="bg ca da de el en_GB es et fi fr hu it ja ka ko nl pt ru sr sr@Latn sv tr zh_TW
+ ar cs gl he lt pa pt_BR ta"
+LANGS_DOC="da es et it nl pt ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde
+
+DESCRIPTION="A user friendly IRC Client for KDE3.x"
+HOMEPAGE="http://konversation.kde.org/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+need-kde 3
+
+PATCHES="${FILESDIR}/${P}-crash.patch
+ ${FILESDIR}/${P}-konsolepanel.patch
+ ${FILESDIR}/${P}-media-script-vulnerability.patch"
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ if ! has_version kde-base/konsole && ! has_version kde-base/kdebase; then
+ echo
+ elog "If you want to be able to use Konsole from inside ${PN}, please emerge either"
+ elog "kde-base/konsole or kde-base/kdebase."
+ echo
+ fi
+}