summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-06-07 21:48:32 +0000
committerSven Wegener <swegener@gentoo.org>2008-06-07 21:48:32 +0000
commit5e0c7c655200b174badbb878d81d9539e256df98 (patch)
tree67047a1e74d03e746cf006c26217d8bf99902233 /net-irc/irssi
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-5e0c7c655200b174badbb878d81d9539e256df98.tar.gz
gentoo-2-5e0c7c655200b174badbb878d81d9539e256df98.tar.bz2
gentoo-2-5e0c7c655200b174badbb878d81d9539e256df98.zip
Another patch to fix bug #202561.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/ChangeLog6
-rw-r--r--net-irc/irssi/files/irssi-0.8.12-svn-4640.patch82
-rw-r--r--net-irc/irssi/irssi-0.8.12.ebuild3
3 files changed, 89 insertions, 2 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index 8f763ae23b7e..93f6a819fd12 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/irssi
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.135 2008/06/07 20:04:46 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.136 2008/06/07 21:48:31 swegener Exp $
+
+ 07 Jun 2008; Sven Wegener <swegener@gentoo.org>
+ +files/irssi-0.8.12-svn-4640.patch, irssi-0.8.12.ebuild:
+ Another patch to fix bug #202561.
07 Jun 2008; Sven Wegener <swegener@gentoo.org>
+files/irssi-0.8.12-svn-4637.patch, irssi-0.8.12.ebuild:
diff --git a/net-irc/irssi/files/irssi-0.8.12-svn-4640.patch b/net-irc/irssi/files/irssi-0.8.12-svn-4640.patch
new file mode 100644
index 000000000000..0fff52a5a1f4
--- /dev/null
+++ b/net-irc/irssi/files/irssi-0.8.12-svn-4640.patch
@@ -0,0 +1,82 @@
+r4640 | jilles | 2007-11-17 16:35:47 +0000 (Sat, 17 Nov 2007) | 4 lines
+
+Do not allow /ping by itself to ctcp ping a channel.
+This is like the new /ver behaviour.
+Bug #542, patch by Geert with tweaks by exg
+
+Index: trunk/src/fe-common/irc/fe-irc-commands.c
+===================================================================
+--- trunk/src/fe-common/irc/fe-irc-commands.c (revision 4639)
++++ trunk/src/fe-common/irc/fe-irc-commands.c (revision 4640)
+@@ -298,7 +298,7 @@
+ cmd_params_free(free_arg);
+ }
+
+-/* SYNTAX: VER [<target>] */
++/* SYNTAX: VER [<nick> | <channel> | *] */
+ static void cmd_ver(gchar *data, IRC_SERVER_REC *server, WI_ITEM_REC *item)
+ {
+ char *str;
+Index: trunk/src/irc/core/irc-commands.c
+===================================================================
+--- trunk/src/irc/core/irc-commands.c (revision 4639)
++++ trunk/src/irc/core/irc-commands.c (revision 4640)
+@@ -504,7 +504,7 @@
+ cmd_params_free(free_arg);
+ }
+
+-/* SYNTAX: PING <nicks> */
++/* SYNTAX: PING [<nick> | <channel> | *] */
+ static void cmd_ping(const char *data, IRC_SERVER_REC *server, WI_ITEM_REC *item)
+ {
+ GTimeVal tv;
+@@ -512,10 +512,9 @@
+
+ CMD_IRC_SERVER(server);
+
+- if (*data == '\0' || strcmp(data, "*") == 0) {
+- if (!IS_IRC_ITEM(item))
+- cmd_return_error(CMDERR_NOT_JOINED);
+-
++ if (*data == '\0') {
++ if (!IS_QUERY(item))
++ cmd_return_error(CMDERR_NOT_ENOUGH_PARAMS);
+ data = window_item_get_target(item);
+ }
+
+Index: trunk/docs/help/in/ping.in
+===================================================================
+--- trunk/docs/help/in/ping.in (revision 4639)
++++ trunk/docs/help/in/ping.in (revision 4640)
+@@ -1,10 +1,10 @@
+
+ @SYNTAX:ping@
+
+-Sends CTCP PING to another IRC client. This is used
+-to find out the speed of IRC network. When the PING
+-reply comes in, irssi shows the interval time between
+-sending the request and receiving the reply.
++Sends CTCP PING to another IRC client or to an IRC channel.
++This is used to find out the speed of IRC network. When
++the PING reply comes in, irssi shows the interval time
++between sending the request and receiving the reply.
+
+ See also: CTCP
+
+Index: trunk/docs/help/in/ver.in
+===================================================================
+--- trunk/docs/help/in/ver.in (revision 4639)
++++ trunk/docs/help/in/ver.in (revision 4640)
+@@ -1,9 +1,9 @@
+
+ @SYNTAX:ver@
+
+-Sends a CTCP VERSION request to the nick. This is used
+-to find out which client and/or script the nick
+-is using.
++Sends a CTCP VERSION request to a nick or channel.
++This is used to find out which client and/or
++script the nick is using.
+
+ See also: CTCP
+
diff --git a/net-irc/irssi/irssi-0.8.12.ebuild b/net-irc/irssi/irssi-0.8.12.ebuild
index 539543f79c0a..e5edd0ad73a4 100644
--- a/net-irc/irssi/irssi-0.8.12.ebuild
+++ b/net-irc/irssi/irssi-0.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.12.ebuild,v 1.11 2008/06/07 20:04:46 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.12.ebuild,v 1.12 2008/06/07 21:48:31 swegener Exp $
inherit perl-module eutils
@@ -32,6 +32,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-svn-4627.patch
epatch "${FILESDIR}"/${P}-svn-4637.patch
+ epatch "${FILESDIR}"/${P}-svn-4640.patch
epatch "${FILESDIR}"/${P}-svn-4829.patch
}