summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-30 13:24:37 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-30 13:24:37 +0000
commitb727b63b009e428debf219226fd5805d6192eae1 (patch)
tree5723e06954fd53a1accafda9be14c2a2cb58d637 /net-irc/dircproxy
parentVersion bump (diff)
downloadgentoo-2-b727b63b009e428debf219226fd5805d6192eae1.tar.gz
gentoo-2-b727b63b009e428debf219226fd5805d6192eae1.tar.bz2
gentoo-2-b727b63b009e428debf219226fd5805d6192eae1.zip
Version bump to 1.2.0_rc1 bug #269200, cleaning out beta
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-irc/dircproxy')
-rw-r--r--net-irc/dircproxy/ChangeLog10
-rw-r--r--net-irc/dircproxy/dircproxy-1.2.0_rc1.ebuild (renamed from net-irc/dircproxy/dircproxy-1.2.0_beta2-r1.ebuild)15
-rw-r--r--net-irc/dircproxy/files/1.2.0-CVE-2007-5226.patch12
3 files changed, 12 insertions, 25 deletions
diff --git a/net-irc/dircproxy/ChangeLog b/net-irc/dircproxy/ChangeLog
index 72fcb211c80d..2e8dfc5776e0 100644
--- a/net-irc/dircproxy/ChangeLog
+++ b/net-irc/dircproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/dircproxy
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/ChangeLog,v 1.25 2009/03/08 03:10:26 dragonheart Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/ChangeLog,v 1.26 2009/08/30 13:24:36 vostorga Exp $
+
+*dircproxy-1.2.0_rc1 (30 Aug 2009)
+
+ 30 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> -dircproxy-1.2.0_beta2-r1.ebuild,
+ +dircproxy-1.2.0_rc1.ebuild, -files/1.2.0-CVE-2007-5226.patch:
+ Version bump to 1.2.0_rc1 bug #269200, cleaning out beta
08 Mar 2009; Daniel Black <dragonheart@gentoo.org>
dircproxy-1.0.5-r1.ebuild, dircproxy-1.1.0-r2.ebuild,
diff --git a/net-irc/dircproxy/dircproxy-1.2.0_beta2-r1.ebuild b/net-irc/dircproxy/dircproxy-1.2.0_rc1.ebuild
index e108f7e46c4f..45b8cc0d28fd 100644
--- a/net-irc/dircproxy/dircproxy-1.2.0_beta2-r1.ebuild
+++ b/net-irc/dircproxy/dircproxy-1.2.0_rc1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/dircproxy-1.2.0_beta2-r1.ebuild,v 1.3 2009/03/09 04:22:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/dircproxy-1.2.0_rc1.ebuild,v 1.1 2009/08/30 13:24:36 vostorga Exp $
inherit eutils
-MY_P="${P/_/-}"
+MY_P="${P/_rc/-RC}"
DESCRIPTION="an IRC proxy server"
HOMEPAGE="http://code.google.com/p/dircproxy"
-SRC_URI="http://dircproxy.googlecode.com/files/${MY_P}.tar.bz"
+SRC_URI="http://dircproxy.googlecode.com/files/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -16,14 +16,7 @@ IUSE=""
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch "${FILESDIR}/1.2.0-CVE-2007-5226.patch"
-}
-
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog FAQ NEWS README* TODO INSTALL
+ dodoc AUTHORS ChangeLog FAQ NEWS HACKING README* TODO INSTALL
}
diff --git a/net-irc/dircproxy/files/1.2.0-CVE-2007-5226.patch b/net-irc/dircproxy/files/1.2.0-CVE-2007-5226.patch
deleted file mode 100644
index 110edc399279..000000000000
--- a/net-irc/dircproxy/files/1.2.0-CVE-2007-5226.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN dircproxy-1.2.0-beta2.orig/src/irc_server.c dircproxy-1.2.0-beta2/src/irc_server.c
---- dircproxy-1.2.0-beta2.orig/src/irc_server.c 2006-10-07 17:07:08.000000000 -0400
-+++ dircproxy-1.2.0-beta2/src/irc_server.c 2007-10-04 17:45:57.000000000 -0400
-@@ -1155,7 +1155,7 @@
-
- if (!strcmp(cmsg.cmd, "ACTION")) {
- irclog_log(p, IRC_LOG_ACTION, logdest, msg.src.orig,
-- "%s", cmsg.paramstarts[0]);
-+ "%s", (cmsg.paramstarts != NULL) ? cmsg.paramstarts[0]: "none");
-
- } else if (!strcmp(cmsg.cmd, "DCC")
- && p->conn_class->dcc_proxy_incoming) {