summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-11 19:18:11 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-11 19:18:11 +0000
commitc4675a6ebdb84af1f9834f4650776ae105911b04 (patch)
treef8938fb7ea9b4ff08409e0f1d47877a2b2ee41bc /net-irc/bitchx
parentadded sidplay (diff)
downloadgentoo-2-c4675a6ebdb84af1f9834f4650776ae105911b04.tar.gz
gentoo-2-c4675a6ebdb84af1f9834f4650776ae105911b04.tar.bz2
gentoo-2-c4675a6ebdb84af1f9834f4650776ae105911b04.zip
Added "DEFINE LATIN1 ON" to include/config.h (bug #10332)
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/ChangeLog13
-rw-r--r--net-irc/bitchx/bitchx-1.0.19-r3.ebuild122
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.19-r31
3 files changed, 134 insertions, 2 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index 0faa7e170459..ca2bdbcceff8 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,15 @@
-# ChangeLog for net-ircbitchxChangeLog/
+# ChangeLog for net-irc/bitchx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.11 2002/10/25 21:53:53 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.12 2002/11/11 19:18:11 phoenix Exp $
+
+*bitchx-1.0.19-r3 (11 Nov 2002)
+
+ 21 Oct 2002; phoen][x <phoenix@gentoo.org> bitchx-1.0.19-r3.ebuild,
+ files/digest-bitchx-1.0.19-r3 :
+
+ Used sed to patch include/config.h. BitchX now compiles with #define LATIN1 ON.
+ This shouldn't break anything but add support for the standard LATIN1 letters.
+ This closes bug #10332.
*bitchx-1.0.19-r2 (26 Jun 2002)
diff --git a/net-irc/bitchx/bitchx-1.0.19-r3.ebuild b/net-irc/bitchx/bitchx-1.0.19-r3.ebuild
new file mode 100644
index 000000000000..870ac8f8e986
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.19-r3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19-r3.ebuild,v 1.1 2002/11/11 19:18:11 phoenix Exp $
+
+IUSE="ssl esd gnome xmms ncurses ipv6 gtk"
+
+MY_P=ircii-pana-${PV/.0./.0c}
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.bitchx.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+inherit flag-o-matic
+replace-flags -O[3-9] -O2
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ xmms? ( media-sound/xmms )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( sys-libs/ncurses )
+ esd? ( >=media-sound/esound-0.2.5
+ >=media-libs/audiofile-0.1.5 )
+ gtk? ( =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1 )"
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ einfo "debugging"
+ myconf="${myconf} --enable-debug"
+ fi
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use esd && use gtk \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ use gtk \
+ || myconf="${myconf} --without-gtk"
+
+ use ipv6 \
+ && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ #not tested
+ #use ncurses \
+ # && myconf="${myconf} --without-tgetent" \
+ # || myconf="${myconf} --with-tgetent"
+
+ # lamer@gentoo.org BROKEN, will not work with our socks
+ # implementations, is looking for a SOCKSConnect function that our
+ # dante packages don't have :-(
+ # use socks5 \
+ # && myconf="${myconf} --with-socks=5" \
+ # || myconf="${myconf} --without-socks"
+
+ mv ${S}/include/config.h ${S}/include/config.h.orig
+ sed -e "s/#undef LATIN1/#define LATIN1 ON/;" \
+ ${S}/include/config.h.orig > \
+ ${S}/include/config.h
+
+ econf \
+ --enable-cdrom \
+ --with-plugins \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ rm ${D}/usr/share/man/man1/BitchX*
+ doman doc/BitchX.1
+
+ use gnome && ( \
+ exeinto /usr/bin
+ newexe ${S}/source/BitchX BitchX-1.0c19
+ dosym gtkBitchX-1.0c19 /usr/bin/gtkBitchX
+ )
+
+ dosym BitchX-1.0c19 /usr/bin/BitchX
+
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ cd ${S}
+ dodoc Changelog README* IPv6-support COPYING
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ dohtml *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ cp acro/README acro/README.acro
+ dodoc acro/README.acro
+ cp arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ cp blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ cp qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.19-r3 b/net-irc/bitchx/files/digest-bitchx-1.0.19-r3
new file mode 100644
index 000000000000..733d621134c6
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.19-r3
@@ -0,0 +1 @@
+MD5 79431ff0880e7317049045981fac8adc ircii-pana-1.0c19.tar.gz 2533621