summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-07-30 16:50:43 +0000
committerJeroen Roovers <jer@gentoo.org>2008-07-30 16:50:43 +0000
commitbd6c5845420ac1e5eb125c833ebc57128029dfd5 (patch)
treed5239bf139a5ec52a5384096d74a8d47952d5fc8 /net-im
parentamd64 stable wrt #232515 and use PREFIX also in src_compile for emake, since ... (diff)
downloadgentoo-2-bd6c5845420ac1e5eb125c833ebc57128029dfd5.tar.gz
gentoo-2-bd6c5845420ac1e5eb125c833ebc57128029dfd5.tar.bz2
gentoo-2-bd6c5845420ac1e5eb125c833ebc57128029dfd5.zip
Version bump (bug #233396).
(Portage version: 2.2_rc4/cvs/Linux 2.6.24-gentoo-r2-JeR i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog7
-rw-r--r--net-im/psi/psi-0.12.ebuild84
-rw-r--r--net-im/psi/psi-0.12_rc4.ebuild4
3 files changed, 92 insertions, 3 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index 54516574785a..5f5d4f408421 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/psi
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.138 2008/07/27 22:00:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.139 2008/07/30 16:50:43 jer Exp $
+
+*psi-0.12 (30 Jul 2008)
+
+ 30 Jul 2008; Jeroen Roovers <jer@gentoo.org> +psi-0.12.ebuild:
+ Version bump.
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> psi-0.10-r3.ebuild,
psi-0.10-r4.ebuild, psi-0.11.ebuild:
diff --git a/net-im/psi/psi-0.12.ebuild b/net-im/psi/psi-0.12.ebuild
new file mode 100644
index 000000000000..9112d4d18d44
--- /dev/null
+++ b/net-im/psi/psi-0.12.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12.ebuild,v 1.1 2008/07/30 16:50:43 jer Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
+HOMEPAGE="http://psi-im.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+IUSE="crypt dbus debug doc kernel_linux spell ssl xscreensaver"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+RESTRICT="test"
+
+COMMON_DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
+ =app-crypt/qca-2*
+ spell? ( app-text/aspell )
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( >=app-crypt/qca-gnupg-2.0.0_beta2 )
+ ssl? ( >=app-crypt/qca-ossl-2.0.0_beta2 )"
+
+pkg_setup() {
+ if has_version "=x11-libs/qt-4.3*"; then
+ QT4_BUILT_WITH_USE_CHECK="qt3support png"
+ QT4_OPTIONAL_BUILT_WITH_USE_CHECK="dbus"
+ else
+ if ! built_with_use "x11-libs/qt-gui:4" qt3support; then
+ eerror "You have to build x11-libs/qt-gui:4 with qt3support."
+ die "qt3support in qt-gui disabled"
+ fi
+ if ( use dbus && ! built_with_use "x11-libs/qt-gui:4" dbus ); then
+ eerror "You have to build x11-libs/qt-gui:4 with dbus"
+ die "dbus in qt-gui disabled"
+ fi
+ fi
+ qt4_pkg_setup
+}
+
+src_compile() {
+ # disable growl as it is a MacOS X extension only
+ local myconf="--prefix=/usr --qtdir=/usr"
+ myconf="${myconf} --disable-growl --disable-bundled-qca"
+ use debug && myconf="${myconf} --enable-debug"
+ use dbus || myconf="${myconf} --disable-qdbus"
+ use kernel_linux || myconf="${myconf} --disable-dnotify"
+ use spell || myconf="${myconf} --disable-aspell"
+ use xscreensaver || myconf="${myconf} --disable-xss"
+
+ # cannot use econf because of non-standard configure script
+ ./configure ${myconf} || die "configure failed"
+
+ eqmake4 ${PN}.pro
+
+ SUBLIBS="-L/usr/${get_libdir}/qca2" emake || die "emake failed"
+
+ if use doc; then
+ cd doc
+ make api_public || die "make api_public failed"
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+
+ # this way the docs will be installed in the standard gentoo dir
+ newdoc iconsets/roster/README README.roster
+ newdoc iconsets/system/README README.system
+ newdoc certs/README README.certs
+ dodoc README
+
+ if use doc; then
+ cd doc
+ dohtml -r api || die "dohtml failed"
+ fi
+}
diff --git a/net-im/psi/psi-0.12_rc4.ebuild b/net-im/psi/psi-0.12_rc4.ebuild
index ca892beaa4ae..38bd22d42b37 100644
--- a/net-im/psi/psi-0.12_rc4.ebuild
+++ b/net-im/psi/psi-0.12_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12_rc4.ebuild,v 1.3 2008/07/26 21:37:20 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12_rc4.ebuild,v 1.4 2008/07/30 16:50:43 jer Exp $
EAPI="1"
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
IUSE="crypt dbus debug doc kernel_linux spell ssl xscreensaver"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
RESTRICT="test"
COMMON_DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )