summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2009-08-18 16:14:30 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2009-08-18 16:14:30 +0000
commita84debf1270851d4931b24cdf081c7d7482f9632 (patch)
tree96a5efbede9cf431589d6c2c1bc8c4c6082adb6b /net-im
parentAvoid dropping stable keywords until stablereqs are done (diff)
downloadgentoo-2-a84debf1270851d4931b24cdf081c7d7482f9632.tar.gz
gentoo-2-a84debf1270851d4931b24cdf081c7d7482f9632.tar.bz2
gentoo-2-a84debf1270851d4931b24cdf081c7d7482f9632.zip
Added pyicq-t 0.8.1.4 (bug #280909)
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pyicq-t/ChangeLog8
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.4.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index c265f929e9bf..8791de1428ed 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/pyicq-t
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.14 2009/05/13 18:45:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.15 2009/08/18 16:14:30 griffon26 Exp $
+
+*pyicq-t-0.8.1.4 (18 Aug 2009)
+
+ 18 Aug 2009; Maurice van der Pot <griffon26@gentoo.org>
+ +pyicq-t-0.8.1.4.ebuild:
+ Version bump.
13 May 2009; Markus Meier <maekke@gentoo.org> pyicq-t-0.8.1.3.ebuild:
amd64/x86 stable, bug #268573
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.4.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.4.ebuild
new file mode 100644
index 000000000000..586ed596fef3
--- /dev/null
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.4.ebuild,v 1.1 2009/08/18 16:14:30 griffon26 Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils multilib python
+
+MY_P="${P/pyicq-t/pyicqt}"
+
+DESCRIPTION="Python based jabber transport for ICQ"
+HOMEPAGE="http://code.google.com/p/pyicqt/"
+SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ >=dev-python/twisted-2.2.0
+ >=dev-python/twisted-words-0.1.0
+ >=dev-python/twisted-web-0.5.0
+ webinterface? ( >=dev-python/nevow-0.4.1 )
+ >=dev-python/imaging-1.1"
+
+src_install() {
+ local inspath
+
+ python_version
+ inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ insinto ${inspath}
+ doins -r data src tools
+ newins PyICQt.py ${PN}.py
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ dosed \
+ "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ /etc/jabber/${PN}.xml
+ dosed \
+ "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ /etc/jabber/${PN}.xml
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
+ dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+
+ elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
+ elog "Please edit it and the configuration of your Jabber server to match."
+
+ ewarn "If you are storing user accounts in MySQL and are upgrading from a "
+ ewarn "version older than 0.8.1, then you will need to run the following "
+ ewarn "command to create some new tables:"
+ ewarn " mysql -u user_name -p pyicqt < /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tools/db-setup.mysql"
+
+ elog "These instructions along with a list of new config variables are "
+ elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
+}