summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-04 18:34:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-04 18:34:49 +0000
commit84ba64e1bdb82a58f4ff3d6f4d5084fa05e5d77f (patch)
tree1fd67f83ac9187838cfdcba1f39e37837fda99ee /net-im
parentVersion bumped. Ebuild submitted by Jiri VERUNEK <verunek@vol.cz> in #20391. (diff)
downloadgentoo-2-84ba64e1bdb82a58f4ff3d6f4d5084fa05e5d77f.tar.gz
gentoo-2-84ba64e1bdb82a58f4ff3d6f4d5084fa05e5d77f.tar.bz2
gentoo-2-84ba64e1bdb82a58f4ff3d6f4d5084fa05e5d77f.zip
Version bumped. Ebuild submitted by Jiri VERUNEK <verunek@vol.cz> in #20391.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/linphone/ChangeLog7
-rw-r--r--net-im/linphone/Manifest2
-rw-r--r--net-im/linphone/files/digest-linphone-0.10.21
-rw-r--r--net-im/linphone/linphone-0.10.2.ebuild51
4 files changed, 59 insertions, 2 deletions
diff --git a/net-im/linphone/ChangeLog b/net-im/linphone/ChangeLog
index a7f083f9af97..4d9f2e2aa2de 100644
--- a/net-im/linphone/ChangeLog
+++ b/net-im/linphone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/linphone
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.3 2003/03/20 14:01:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.4 2003/05/04 18:34:37 mholzer Exp $
+
+*linphone-0.10.2 (04 May 2003)
+
+ 04 May 2003; Martin Holzer <mholzer@gentoo.org> linphone-0.10.2.ebuild:
+ Version bumped. Ebuild submitted by Jiri VERUNEK <verunek@vol.cz> in #20391.
*linphone-0.9.0-r1 (20 Mar 2003)
diff --git a/net-im/linphone/Manifest b/net-im/linphone/Manifest
index 0225752afa08..555d01e7b3c0 100644
--- a/net-im/linphone/Manifest
+++ b/net-im/linphone/Manifest
@@ -1,4 +1,4 @@
-MD5 6b449ae5ec1719410fa15b8c8549e56e ChangeLog 592
+MD5 ee8d74c6532fb9d21587e68a3f394bc7 ChangeLog 778
MD5 a3d8f2f4dc288b2d1ac1fb07c1f918e5 linphone-0.9.0.ebuild 1373
MD5 c59b6d0f0d832aefbce563233b014d54 linphone-0.9.0-r1.ebuild 1376
MD5 69a481c7d3865479a4e4286251e6a736 linphone-0.10.2.ebuild 1448
diff --git a/net-im/linphone/files/digest-linphone-0.10.2 b/net-im/linphone/files/digest-linphone-0.10.2
new file mode 100644
index 000000000000..276919c36200
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.10.2
@@ -0,0 +1 @@
+MD5 b61a3ffb88791ef22c1462bacbba2aee linphone-0.10.2.tar.gz 2701500
diff --git a/net-im/linphone/linphone-0.10.2.ebuild b/net-im/linphone/linphone-0.10.2.ebuild
new file mode 100644
index 000000000000..e377da613f99
--- /dev/null
+++ b/net-im/linphone/linphone-0.10.2.ebuild
@@ -0,0 +1,51 @@
+IUSE="doc gtk nls xv alsa"
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface. It let you make two-party calls over IP networks such as the Internet. It uses the IETF protocols SIP (Session Initiation Protocol) and RTP (Realtime Transport Protocol) to make calls, so it should be able to communicate with other SIP-based Web phones. With several codecs available, it can be used with high speed connections as well as 28k modems."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${PV}/sources/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-libs/glib
+ >=net-libs/libosip-0.9.6
+ dev-util/pkgconfig
+ xv? ( dev-lang/nasm )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ gnome? ( gnome-base/gnome-panel
+ gnome-base/libgnome
+ gnome-base/libgnomeui )
+ alsa? ( >media-sound/alsa-driver-0.5 )
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+
+ local myconf
+
+ if use gnome
+ then
+ use gtk2 && myconf="${myconf} --enable-platform-gnome-2"
+ else
+ use gnome || myconf="${myconf}--enable-gnome_ui=no"
+ fi
+
+ if use gtk && use doc
+ then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}