summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-09 16:35:15 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-09 16:35:15 +0000
commit31f11739bae5be1d46cf8336a1a31eb2f1a0d015 (patch)
treea70c7da4b2877d303a96ede6510229c654a3b728 /net-im
parentVersion bumped. Removed useless .la files, bug #299016. (diff)
downloadgentoo-2-31f11739bae5be1d46cf8336a1a31eb2f1a0d015.tar.gz
gentoo-2-31f11739bae5be1d46cf8336a1a31eb2f1a0d015.tar.bz2
gentoo-2-31f11739bae5be1d46cf8336a1a31eb2f1a0d015.zip
net-im/qutecom: new ebuild for bug 237941
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutecom/ChangeLog10
-rw-r--r--net-im/qutecom/metadata.xml10
-rw-r--r--net-im/qutecom/qutecom-2.2_p20100309.ebuild63
3 files changed, 83 insertions, 0 deletions
diff --git a/net-im/qutecom/ChangeLog b/net-im/qutecom/ChangeLog
new file mode 100644
index 000000000000..488dbcdce3e5
--- /dev/null
+++ b/net-im/qutecom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-im/qutecom
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/ChangeLog,v 1.1 2010/03/09 16:35:15 chithanh Exp $
+
+*qutecom-2.2_p20100309 (09 Mar 2010)
+
+ 09 Mar 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +qutecom-2.2_p20100309.ebuild:
+ initial import for bug 237941
+
diff --git a/net-im/qutecom/metadata.xml b/net-im/qutecom/metadata.xml
new file mode 100644
index 000000000000..11b753103370
--- /dev/null
+++ b/net-im/qutecom/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>voip</herd>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-im/qutecom/qutecom-2.2_p20100309.ebuild b/net-im/qutecom/qutecom-2.2_p20100309.ebuild
new file mode 100644
index 000000000000..8c93c9b131a0
--- /dev/null
+++ b/net-im/qutecom/qutecom-2.2_p20100309.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/qutecom-2.2_p20100309.ebuild,v 1.1 2010/03/09 16:35:15 chithanh Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Multi-protocol instant messenger and VoIP client"
+HOMEPAGE="http://www.qutecom.org/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug oss portaudio xv"
+
+RDEPEND="dev-libs/boost
+ dev-libs/glib
+ dev-libs/openssl
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ portaudio? ( media-libs/portaudio )
+ media-libs/speex
+ media-video/ffmpeg
+ net-im/pidgin[gnutls]
+ net-libs/gnutls
+ >=net-libs/libosip-3
+ >=net-libs/libeXosip-3
+ net-misc/curl
+ x11-libs/libX11
+ x11-libs/qt-gui
+ x11-libs/qt-svg
+ xv? ( x11-libs/libXv )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.41" && has_version ">=dev-libs/boost-1.41"; then
+ ewarn "QuteCom build system may mix up headers and libraries if versions of"
+ ewarn "dev-libs/boost both before and after 1.41 are installed. If the build"
+ ewarn "fails due to undefined boost symbols, remove older boost."
+ fi
+}
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_enable portaudio PORTAUDIO_SUPPORT)
+ $(cmake-utils_use_enable alsa PHAPI_AUDIO_ALSA_SUPPORT)
+ $(cmake-utils_use_enable oss PHAPI_AUDIO_OSS_SUPPORT)
+ $(cmake-utils_use_enable xv WENGOPHONE_XV_SUPPORT)
+ -DLIBPURPLE_INTERNAL=OFF
+ -DPORTAUDIO_INTERNAL=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu wengophone/res/${PN}.desktop || die "domenu failed"
+ doicon wengophone/res/${PN}_64x64.png || die "doicon failed"
+
+}