summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-08 09:43:43 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-08 09:43:43 +0000
commit1e23e5bcb8f34797129c7db7bc8c58f46973cc57 (patch)
treebfc851100a73b72672cd6337388491966e70966b /net-im
parentchanged several "dodir"s to "keepdir" since people were having (diff)
downloadgentoo-2-1e23e5bcb8f34797129c7db7bc8c58f46973cc57.tar.gz
gentoo-2-1e23e5bcb8f34797129c7db7bc8c58f46973cc57.tar.bz2
gentoo-2-1e23e5bcb8f34797129c7db7bc8c58f46973cc57.zip
fixes so that kde-enabled version compiles correctly
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/licq-1.0.4.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/net-im/licq/licq-1.0.4.ebuild b/net-im/licq/licq-1.0.4.ebuild
index 5a21efdd50ec..634ccffa9044 100644
--- a/net-im/licq/licq-1.0.4.ebuild
+++ b/net-im/licq/licq-1.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4.ebuild,v 1.2 2001/12/08 00:11:32 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4.ebuild,v 1.3 2001/12/08 09:43:43 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
use kde && inherit kde-base || die
@@ -16,18 +16,12 @@ use kde && need-qt 2.2
src_compile() {
local first_conf
- local second_conf
cd ${S}
make -f Makefile.cvs || die
- if [-z "`use ssl`"]
- then
- first_conf = "${first_conf} --disable-openssl"
- fi
- if [ "`use socks5`" ]
- then
- first_conf = "${first_conf} --enable-socks5"
- fi
+
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
emake || die
@@ -35,12 +29,13 @@ src_compile() {
if [ "`use qt`" ]
then
- cd plugins/qt-gui-1.0.4
- make -f Makefile.cvs || die
- use kde && kde_src_compile second_conf
- use kde && second_conf="${second_conf} --with-kde"
- ./configure --host=${CHOST} --prefix=/usr ${second_conf} || die
- emake || die
+ cd plugins/qt-gui-1.0.4
+ make -f Makefile.cvs || die
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+ ./configure --host=${CHOST} --prefix=/usr ${second_conf} || die
+ emake || die
+
fi
}