summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-11 14:53:34 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-11 14:53:34 +0000
commit12a44679a72e1a1a50d1eb861e473eb0e42ec5e6 (patch)
treefeeb749a23922b6027a417ec9099c98a14f6fbd8 /net-im
parentversion bump and use keyword masking for recent versions (diff)
downloadgentoo-2-12a44679a72e1a1a50d1eb861e473eb0e42ec5e6.tar.gz
gentoo-2-12a44679a72e1a1a50d1eb861e473eb0e42ec5e6.tar.bz2
gentoo-2-12a44679a72e1a1a50d1eb861e473eb0e42ec5e6.zip
Keyword masked version bumpage
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/files/digest-gaim-0.59.41
-rw-r--r--net-im/gaim/gaim-0.59.4.ebuild101
3 files changed, 110 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 26b8b5125dc0..55b102c13ccc 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.25 2002/09/24 15:36:48 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.26 2002/10/11 14:53:34 lostlogic Exp $
+
+*gaim-0.59.4 (07 Oct 2002)
+
+ 07 Oct 2002; Brandon Low <lostlogic@gentoo.org> gaim-0.59.4.ebuild :
+
+ Version new. Bug fixes, hopefully stops crashing all the time for
+ me. Now use keyword masking.
*gaim-0.59.3 (19 Sep 2002)
diff --git a/net-im/gaim/files/digest-gaim-0.59.4 b/net-im/gaim/files/digest-gaim-0.59.4
new file mode 100644
index 000000000000..cc88d32f6a04
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.59.4
@@ -0,0 +1 @@
+MD5 809fa0b413f4dc1dad2b4c154accdcd5 gaim-0.59.4.tar.bz2 1530045
diff --git a/net-im/gaim/gaim-0.59.4.ebuild b/net-im/gaim/gaim-0.59.4.ebuild
new file mode 100644
index 000000000000..1636535d433a
--- /dev/null
+++ b/net-im/gaim/gaim-0.59.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.59.4.ebuild,v 1.1 2002/10/11 14:53:34 lostlogic Exp $
+
+IUSE="nas nls esd gnome arts gtk2 perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK Instant Messenger client"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+HOMEPAGE="http://gaim.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( sys-devel/gettext )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gtk2? ( =x11-libs/gtk+-2.0* =dev-libs/glib-2.0* )
+ || ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2*
+ ( gnome? ( =gnome-base/gnome-panel-1.4* >=media-libs/gdk-pixbuf-0.16.0 ) ) )"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # patch for korean encoding
+ # It should be ok with other languages
+ # the patch only works with nls
+ # PULLED -- got complaints it was hosing gtk2 non-korean users
+ # use nls && patch -p0 < ${FILESDIR}/${P}-korean.patch
+
+}
+
+src_compile() {
+
+ local myconf gnomeopts
+
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas \
+ && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ if [ "` use arts`" ]; then
+ inherit kde-functions
+ set-kdedir 3
+ # $KDEDIR now points to arts location
+ else
+ myconf="${myconf} --disable-artsc"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ gnomeopts="${myconf}"
+
+ if [ "`use gtk2`" ];
+ then
+
+ # GTK+ 2 support
+ myconf="${myconf} --enable-gtk2"
+
+ fi
+
+ gnomeopts="${myconf}"
+
+ # Gnome is disabled for GTK+ 2.0 build and first build of GTK 1.4 version
+ myconf="${myconf} --disable-gnome"
+
+ # always build standalone gaim program
+ econf ${myconf} || die
+ emake || die
+
+ # if gnome support is enabled (and gtk2 disabled), then build gaim_applet
+ if [ use gnome -a -z "`use gtk2`" ];
+ then
+ gnomeopts="${gnomeopts} --with-gnome=${GNOME_PATH} --enable-panel"
+
+ # save appletless version and clean up
+ cp src/gaim ${S}/gaim || die "standalone version failed to build"
+ make distclean || die
+
+ econf ${gnomeopts} || die
+ emake || die
+ fi
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ # if gnome enabled, make sure to install standalone version also
+ use gnome && dobin ${S}/gaim
+
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}