summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-10-07 11:00:59 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-10-07 11:00:59 +0000
commit08ba2d8d70a5b529a564374acce1be70c2a3ce24 (patch)
treeb9371d3bc85826d5fb0372f0ec18c1bd88f87c2e /net-im/vacuum
parentDrop old and unused patches (diff)
downloadgentoo-2-08ba2d8d70a5b529a564374acce1be70c2a3ce24.tar.gz
gentoo-2-08ba2d8d70a5b529a564374acce1be70c2a3ce24.tar.bz2
gentoo-2-08ba2d8d70a5b529a564374acce1be70c2a3ce24.zip
Version bump, thanks to Nikoli
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-im/vacuum')
-rw-r--r--net-im/vacuum/ChangeLog7
-rw-r--r--net-im/vacuum/vacuum-1.2.3.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/net-im/vacuum/ChangeLog b/net-im/vacuum/ChangeLog
index 6ff557f24ffd..45042811a1a3 100644
--- a/net-im/vacuum/ChangeLog
+++ b/net-im/vacuum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/vacuum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.16 2013/10/07 10:59:18 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.17 2013/10/07 11:00:59 pinkbyte Exp $
+
+*vacuum-1.2.3 (07 Oct 2013)
+
+ 07 Oct 2013; Sergey Popov <pinkbyte@gentoo.org> +vacuum-1.2.3.ebuild:
+ Version bump, thanks to Nikoli
07 Oct 2013; Sergey Popov <pinkbyte@gentoo.org>
-files/vacuum-1.1.1-minizip.patch, -files/vacuum-1.1.1-zlib.patch:
diff --git a/net-im/vacuum/vacuum-1.2.3.ebuild b/net-im/vacuum/vacuum-1.2.3.ebuild
new file mode 100644
index 000000000000..78b9439afd1d
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.2.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.2.3.ebuild,v 1.1 2013/10/07 11:00:59 pinkbyte Exp $
+
+EAPI="5"
+LANGS="de pl ru uk"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Crossplatform Jabber client."
+HOMEPAGE="http://code.google.com/p/vacuum-im"
+SRC_URI="http://vacuum-im.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/1.17"
+KEYWORDS="~amd64 ~x86"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
+IUSE="${PLUGINS// / +}"
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ birthdayreminder? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filemessagearchive? ( messagearchiver )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ pepmanager? ( servicediscovery )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ servermessagearchive? ( messagearchiver )
+ sessionnegotiation? ( dataforms )
+"
+
+RDEPEND="
+ >=dev-qt/qtcore-4.5:4[ssl]
+ >=dev-qt/qtgui-4.5:4
+ dev-qt/qtlockedfile
+ >=dev-libs/openssl-0.9.8k
+ adiummessagestyle? ( >=dev-qt/qtwebkit-4.5:4 )
+ net-dns/libidn
+ x11-libs/libXScrnSaver
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS CHANGELOG README TRANSLATORS"
+
+src_prepare() {
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{idn,minizip,zlib}
+}
+
+src_configure() {
+ # linguas
+ local langs="none;" x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+="${x};"
+ done
+
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="${langs}"
+ -DINSTALL_DOCS=OFF
+ -DFORCE_BUNDLED_MINIZIP=OFF
+ )
+
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
+ done
+
+ cmake-utils_src_configure
+}