summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2008-01-25 00:19:06 +0000
committerGustavo Felisberto <humpback@gentoo.org>2008-01-25 00:19:06 +0000
commitfb0aabb10c7420653cc6a10413b5181fd1d87359 (patch)
tree2fefe098e7b29064e9f02256ddb415cfeac5b14e /net-im/openfire
parentwhitespace (diff)
downloadgentoo-2-fb0aabb10c7420653cc6a10413b5181fd1d87359.tar.gz
gentoo-2-fb0aabb10c7420653cc6a10413b5181fd1d87359.tar.bz2
gentoo-2-fb0aabb10c7420653cc6a10413b5181fd1d87359.zip
bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-im/openfire')
-rw-r--r--net-im/openfire/files/buildxml-3.4.4.patch20
-rw-r--r--net-im/openfire/files/digest-openfire-3.4.43
-rw-r--r--net-im/openfire/openfire-3.4.4.ebuild103
3 files changed, 126 insertions, 0 deletions
diff --git a/net-im/openfire/files/buildxml-3.4.4.patch b/net-im/openfire/files/buildxml-3.4.4.patch
new file mode 100644
index 000000000000..eb52f286d250
--- /dev/null
+++ b/net-im/openfire/files/buildxml-3.4.4.patch
@@ -0,0 +1,20 @@
+--- build/build.xml 2007-04-13 21:00:32.000000000 +0000
++++ build/build.xml 2007-04-16 23:11:05.000000000 +0000
+@@ -1133,7 +1133,7 @@
+
+ </target>
+ <target name="-plugins-impl" if="dirlist">
+-
++ <taskdef classname="net.sf.antcontrib.logic.For" name="for"/>
+ <!-- For each plugin in the main src dir, call the 'buildplugin' macro -->
+ <for list="${dirlist}" param="plugin" trim="true">
+ <sequential>
+@@ -1143,7 +1143,7 @@
+
+ </target>
+ <target name="-plugins-impl-dev" if="plugin.dev.dir">
+-
++ <taskdef classname="net.sf.antcontrib.logic.For" name="for"/>
+ <!-- Get a list of plugins in the optional dev dir -->
+ <subdirinfo dir="${plugin.dev.dir}" property="dirlist2" ifexists="plugin.xml"/>
+
diff --git a/net-im/openfire/files/digest-openfire-3.4.4 b/net-im/openfire/files/digest-openfire-3.4.4
new file mode 100644
index 000000000000..9f4bb8572da4
--- /dev/null
+++ b/net-im/openfire/files/digest-openfire-3.4.4
@@ -0,0 +1,3 @@
+MD5 c773d8b74020c0b5ce19efad9ec682b3 openfire_src_3_4_4.tar.gz 48393969
+RMD160 32a85e1d348813d4cbdb7e0016ba0b777af0dbce openfire_src_3_4_4.tar.gz 48393969
+SHA256 0a3794ce5db9d2d16091d6eb6c1d4d4f8f1065f65e6fc4b3bd512dfb414be924 openfire_src_3_4_4.tar.gz 48393969
diff --git a/net-im/openfire/openfire-3.4.4.ebuild b/net-im/openfire/openfire-3.4.4.ebuild
new file mode 100644
index 000000000000..aa1ecad29b89
--- /dev/null
+++ b/net-im/openfire/openfire-3.4.4.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.4.4.ebuild,v 1.1 2008/01/25 00:19:05 humpback Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Openfire (formerly wildfire) real time collaboration (RTC) server"
+HOMEPAGE="http://www.igniterealtime.org/projects/openfire/"
+SRC_URI="http://www.igniterealtime.org/builds/openfire/${PN//-/_}_src_${PV//./_}.tar.gz"
+RESTRICT=""
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# For transports
+PROVIDE="virtual/jabber-server"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="net-im/jabber-base
+ dev-java/ant-contrib
+ >=virtual/jdk-1.5"
+
+S=${WORKDIR}/${PN//-/_}_src
+
+pkg_setup() {
+ if [ -f /etc/env.d/98openfire ]; then
+ einfo "This is an upgrade"
+ else
+ ewarn "If this is an upgrade stop right ( CONTROL-C ) and run the command:"
+ ewarn "echo 'CONFIG_PROTECT=\"/opt/openfire/resources/security/\"' > /etc/env.d/98openfire "
+ ewarn "For more info see bug #139708"
+ sleep 11
+ fi
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${PN//-/_}_src_${PV//./_}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/buildxml-${PV}.patch
+
+ # TODO should replace jars in build/lib with ones packaged by us -nichoj
+}
+
+src_compile() {
+ # Jikes doesn't support -source 1.5
+ java-pkg_filter-compiler jikes
+
+ ANT_TASKS="ant-contrib"
+ eant -f build/build.xml openfire plugins $(use_doc)
+}
+
+src_install() {
+ dodir /opt/openfire
+
+ doinitd ${FILESDIR}/init.d/openfire
+ doconfd ${FILESDIR}/conf.d/openfire
+
+ dodir /opt/openfire/conf
+ insinto /opt/openfire/conf
+ newins target/openfire/conf/openfire.xml openfire.xml.sample
+
+ dodir /opt/openfire/logs
+ keepdir /opt/openfire/logs
+
+ dodir /opt/openfire/lib
+ insinto /opt/openfire/lib
+ doins target/openfire/lib/*
+
+ dodir /opt/openfire/plugins
+ insinto /opt/openfire/plugins
+ doins -r target/openfire/plugins/*
+
+ dodir /opt/openfire/resources
+ insinto /opt/openfire/resources
+ doins -r target/openfire/resources/*
+
+ if use doc; then
+ dohtml -r documentation/docs/*
+ fi
+ dodoc documentation/dist/*
+
+ #Protect ssl key on upgrade
+ dodir /etc/env.d/
+ echo 'CONFIG_PROTECT="/opt/openfire/resources/security/"' > ${D}/etc/env.d/98openfire
+}
+
+pkg_postinst() {
+ chown -R jabber:jabber /opt/openfire
+
+ ewarn If this is a new install, please edit /opt/openfire/conf/openfire.xml.sample
+ ewarn and save it as /opt/openfire/conf/openfire.xml
+ ewarn
+ ewarn The following must be be owned or writable by the jabber user.
+ ewarn /opt/openfire/conf/openfire.xml
+ ewarn
+ ewarn If you are upgrading please have a look at the Wildfire to Openfire Upgrade Guide:
+ ewarn http://wiki.igniterealtime.org/display/WILDFIRE/Wildfire+to+Openfire+Upgrade+Guide
+ ewarn
+}