summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2004-07-29 23:25:00 +0000
committerStefan Knoblich <stkn@gentoo.org>2004-07-29 23:25:00 +0000
commit522e8683706e569b0beeb748b98a73c5042433ee (patch)
treef3a221beb93c78bf202840770a3cba7665e882be /net-im/linphone
parent5.8.4-r1, many changes, see changelog, bugs 58620 and 52660 (Manifest recommit) (diff)
downloadgentoo-2-522e8683706e569b0beeb748b98a73c5042433ee.tar.gz
gentoo-2-522e8683706e569b0beeb748b98a73c5042433ee.tar.bz2
gentoo-2-522e8683706e569b0beeb748b98a73c5042433ee.zip
version bump
Diffstat (limited to 'net-im/linphone')
-rw-r--r--net-im/linphone/ChangeLog8
-rw-r--r--net-im/linphone/files/digest-linphone-0.12.21
-rw-r--r--net-im/linphone/files/linphone-0.12.2-include-fix.diff16
-rw-r--r--net-im/linphone/linphone-0.12.2.ebuild68
4 files changed, 92 insertions, 1 deletions
diff --git a/net-im/linphone/ChangeLog b/net-im/linphone/ChangeLog
index 8cddd1b36513..04fada63d28c 100644
--- a/net-im/linphone/ChangeLog
+++ b/net-im/linphone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/linphone
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.16 2004/06/24 22:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.17 2004/07/29 23:25:00 stkn Exp $
+
+*linphone-0.12.2 (30 Jul 2004)
+
+ 30 Jul 2004; <stkn@gentoo.org> +files/linphone-0.12.2-include-fix.diff,
+ +linphone-0.12.2.ebuild:
+ version bump
10 Jun 2004; Aron Griffis <agriffis@gentoo.org> linphone-0.12.1.ebuild:
Fix use invocation
diff --git a/net-im/linphone/files/digest-linphone-0.12.2 b/net-im/linphone/files/digest-linphone-0.12.2
new file mode 100644
index 000000000000..ace4fd1f330b
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.12.2
@@ -0,0 +1 @@
+MD5 86c01dbbcdb41786229f51ec0994ff67 linphone-0.12.2.tar.gz 3044602
diff --git a/net-im/linphone/files/linphone-0.12.2-include-fix.diff b/net-im/linphone/files/linphone-0.12.2-include-fix.diff
new file mode 100644
index 000000000000..a5b47f9eae32
--- /dev/null
+++ b/net-im/linphone/files/linphone-0.12.2-include-fix.diff
@@ -0,0 +1,16 @@
+--- linphone-0.12.1/coreapi/linphonecore.c.orig 2003-12-07 18:29:04.000000000 +0000
++++ linphone-0.12.1/coreapi/linphonecore.c 2003-12-07 18:30:42.000000000 +0000
+@@ -34,9 +34,11 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+-#ifdef INET6
++/*
++ shoot me if this breaks, stkn
++ (at least it compiles now, w/o use="ipv6")
++*/
+ #include <netdb.h>
+-#endif
+
+ #define MAX_IF 20
+ const double bandwidths[5]=
diff --git a/net-im/linphone/linphone-0.12.2.ebuild b/net-im/linphone/linphone-0.12.2.ebuild
new file mode 100644
index 000000000000..b316732ec125
--- /dev/null
+++ b/net-im/linphone/linphone-0.12.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/linphone-0.12.2.ebuild,v 1.1 2004/07/29 23:25:00 stkn Exp $
+
+inherit eutils
+
+IUSE="doc gnome nls xv alsa ipv6"
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${PV}/source/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="dev-libs/glib
+ <net-libs/libosip-2.0.0
+ dev-util/pkgconfig
+ x86? (
+ xv? ( dev-lang/nasm )
+ )
+ gnome? (
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2
+ )
+ alsa? ( >media-libs/alsa-lib-0.5 )
+ doc? ( dev-util/gtk-doc )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-include-fix.diff
+}
+
+src_compile() {
+
+ local myconf
+
+ if use gnome
+ then
+ einfo "Building with Gnome gui"
+ myconf="${myconf} --enable-gnome_ui=yes"
+ myconf="${myconf} --enable-platform-gnome-2"
+ else
+ einfo "Building without Gnome gui"
+ myconf="${myconf} --enable-gnome_ui=no"
+ fi
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ `use_enable ipv6` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}