summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-11-06 21:49:24 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-11-06 21:49:24 +0000
commit60901c75b3cd526c7c42b5da90dc8bfefea32f1f (patch)
tree9735e905a497f22b3817adb4b521ba024f0ea9cf /net-im/centericq
parentUn-masked for sparc as needed for kde, will wait for the bugs.... (diff)
downloadgentoo-2-60901c75b3cd526c7c42b5da90dc8bfefea32f1f.tar.gz
gentoo-2-60901c75b3cd526c7c42b5da90dc8bfefea32f1f.tar.bz2
gentoo-2-60901c75b3cd526c7c42b5da90dc8bfefea32f1f.zip
Fixed configure bug. Fixes #10298. Submitted by Thomas Weidner
Diffstat (limited to 'net-im/centericq')
-rw-r--r--net-im/centericq/ChangeLog6
-rw-r--r--net-im/centericq/centericq-4.8.7.ebuild4
-rw-r--r--net-im/centericq/files/centericq-4.8.7-compilefix.patch39
3 files changed, 47 insertions, 2 deletions
diff --git a/net-im/centericq/ChangeLog b/net-im/centericq/ChangeLog
index 6ca8a156c590..baaf901206ec 100644
--- a/net-im/centericq/ChangeLog
+++ b/net-im/centericq/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-im/centericq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/ChangeLog,v 1.11 2002/11/04 06:39:17 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/ChangeLog,v 1.12 2002/11/06 21:49:24 rphillips Exp $
*centericq-4.8.7 (04 Nov 2002)
+ 06 Nov 2002; Ryan Phillips <rphillips@gentoo.org> centericq-4.8.7.ebuild :
+
+ Added libsig++ patch. Fixes #10298. Thanks to Thomas Weidner for submitting the patch.
+
04 Nov 2002; L. Boshell <leonardop@gentoo.org> centericq-4.8.7.ebuild :
New version. Added glib-1.2 dependency and removed the patch for
po/Makefile.in.in since using `einstall' should correct that problem.
diff --git a/net-im/centericq/centericq-4.8.7.ebuild b/net-im/centericq/centericq-4.8.7.ebuild
index 2a0b968c2bf4..ba8693873d31 100644
--- a/net-im/centericq/centericq-4.8.7.ebuild
+++ b/net-im/centericq/centericq-4.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/centericq-4.8.7.ebuild,v 1.1 2002/11/04 06:39:17 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/centericq-4.8.7.ebuild,v 1.2 2002/11/06 21:49:24 rphillips Exp $
IUSE="nls"
@@ -23,6 +23,8 @@ RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myopts=""
+ patch -p1 < ${FILESDIR}/${P}-compilefix.patch
+
use nls || myopts="--disable-nls"
econf --with-included-gettext \
diff --git a/net-im/centericq/files/centericq-4.8.7-compilefix.patch b/net-im/centericq/files/centericq-4.8.7-compilefix.patch
new file mode 100644
index 000000000000..6eb3f3535d2c
--- /dev/null
+++ b/net-im/centericq/files/centericq-4.8.7-compilefix.patch
@@ -0,0 +1,39 @@
+diff -ru centericq-4.8.7/configure centericq-4.8.7-patched/configure
+--- centericq-4.8.7/configure 2002-11-01 16:39:11.000000000 +0100
++++ centericq-4.8.7-patched/configure 2002-11-05 23:09:37.000000000 +0100
+@@ -1587,7 +1587,7 @@
+ fi
+
+ if test "x$no_sigc" = x ; then
+- CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS" LIBS="$LIBS $SIGC_LIBS"
++ CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS"
+ else
+ SIGC_CFLAGS=""
+ SIGC_LIBS=""
+@@ -4468,6 +4468,7 @@
+ GT_YES="#YES#"
+ fi
+
++ LIBS="$LIBS $SIGC_LIBS"
+
+
+ MKINSTALLDIRS=
+diff -ru centericq-4.8.7/configure.in centericq-4.8.7-patched/configure.in
+--- centericq-4.8.7/configure.in 2002-11-01 16:38:40.000000000 +0100
++++ centericq-4.8.7-patched/configure.in 2002-11-05 23:24:42.000000000 +0100
+@@ -24,7 +24,7 @@
+ ### sigc++ check
+
+ AM_PATH_SIGC(1.0.0,
+- [CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS" LIBS="$LIBS $SIGC_LIBS"],
++ [CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS"],
+ [AC_MSG_ERROR([You need to have the libsigc++ libraries installed - see the README for more information])])
+
+ ### use option --with-fribidi to compile with fribidi support
+@@ -88,5 +88,6 @@
+
+ ALL_LINGUAS="zh_TW.Big5 uk sv ru ro pt_BR pl nl ms it hu fr es de cs"
+ AM_GNU_GETTEXT
++LIBS="$LIBS $SIGC_LIBS"
+ AC_CONFIG_SUBDIRS(kkconsui-0.1 kkstrtext-0.1 kksystr-0.1 libicq2000-0.3.3 libmsn-0.1 firetalk-0.1 libyahoo2-0.1)
+ AC_OUTPUT(Makefile contrib/Makefile contrib/spanish/Makefile misc/Makefile share/Makefile src/Makefile src/hooks/Makefile po/Makefile.in intl/Makefile)