summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-11 13:13:47 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-11 13:13:47 +0000
commitdd354e58905eca7af63a5babf2f317154ef44765 (patch)
tree8608d5832be952743473f823a8e86a1ff3f30f41 /net-ftp
parentuse readme.gentoo eclass (bug 487552) (diff)
downloadgentoo-2-dd354e58905eca7af63a5babf2f317154ef44765.tar.gz
gentoo-2-dd354e58905eca7af63a5babf2f317154ef44765.tar.bz2
gentoo-2-dd354e58905eca7af63a5babf2f317154ef44765.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.4.10.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 6799454ef57b..2bf59c8cc51e 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.432 2013/10/07 13:19:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.433 2013/10/11 13:13:47 jer Exp $
+
+*lftp-4.4.10 (11 Oct 2013)
+
+ 11 Oct 2013; Jeroen Roovers <jer@gentoo.org> +lftp-4.4.10.ebuild:
+ Version bump.
07 Oct 2013; Jeroen Roovers <jer@gentoo.org> lftp-4.4.9-r1.ebuild:
Add another dependency.
diff --git a/net-ftp/lftp/lftp-4.4.10.ebuild b/net-ftp/lftp/lftp-4.4.10.ebuild
new file mode 100644
index 000000000000..cb3bceb68f1d
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.4.10.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.10.ebuild,v 1.1 2013/10/11 13:13:47 jer Exp $
+
+EAPI=5
+inherit autotools eutils libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://${PN}.yar.ru/ftp/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="convert-mozilla-cookies +gnutls nls openssl socks5 +ssl verify-file"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ ssl? ( ^^ ( openssl gnutls ) )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-5.1
+ dev-libs/expat
+ sys-libs/zlib
+ convert-mozilla-cookies? ( dev-perl/DBI )
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam
+ )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ openssl? ( >=dev-libs/openssl-0.9.6 )
+ )
+ verify-file? (
+ dev-perl/string-crc32
+ virtual/perl-Digest-MD5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-4.0.2.91-lafile.patch" \
+ "${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
+ "${FILESDIR}/${PN}-4.3.8-gets.patch"
+ sed -i configure.ac -e 's|^AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ $(use_with openssl openssl "${EPREFIX}"/usr) \
+ $(use_with socks5 socksdante "${EPREFIX}"/usr) \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}
+
+src_install() {
+ default
+ local script
+ for script in {convert-mozilla-cookies,verify-file}; do
+ use ${script} || { rm "${D}"/usr/share/${PN}/${script} || die ;}
+ done
+}