summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-21 12:45:58 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-21 12:45:58 +0000
commitd3eee7229af4a0c03bc6b053930f07a7233ec3c2 (patch)
tree22dd811471fa9e6fc17dd40cd132e0a7a1e23e8e /net-ftp
parentgone (diff)
downloadgentoo-2-d3eee7229af4a0c03bc6b053930f07a7233ec3c2.tar.gz
gentoo-2-d3eee7229af4a0c03bc6b053930f07a7233ec3c2.tar.bz2
gentoo-2-d3eee7229af4a0c03bc6b053930f07a7233ec3c2.zip
Version bump (masked development snapshot).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.0.9.1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 1571000d5636..46f677765c10 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.266 2010/07/16 17:56:35 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.267 2010/07/21 12:45:58 jer Exp $
+
+*lftp-4.0.9.1 (21 Jul 2010)
+
+ 21 Jul 2010; Jeroen Roovers <jer@gentoo.org> +lftp-4.0.9.1.ebuild:
+ Version bump (masked development snapshot).
16 Jul 2010; Christian Faulhammer <fauli@gentoo.org> lftp-4.0.9.ebuild:
stable x86, bug 327979
diff --git a/net-ftp/lftp/lftp-4.0.9.1.ebuild b/net-ftp/lftp/lftp-4.0.9.1.ebuild
new file mode 100644
index 000000000000..2b227e380d3b
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.0.9.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.0.9.1.ebuild,v 1.1 2010/07/21 12:45:58 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/devel/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ epatch "${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}