summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-06-28 18:44:55 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-06-28 18:44:55 +0000
commit434f91d4c0b0a082d28ae305923ac7bdfdb77e14 (patch)
tree798cc8cac0ad2451c6ba42573fd78331bf6a9965 /net-ftp
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-434f91d4c0b0a082d28ae305923ac7bdfdb77e14.tar.gz
gentoo-2-434f91d4c0b0a082d28ae305923ac7bdfdb77e14.tar.bz2
gentoo-2-434f91d4c0b0a082d28ae305923ac7bdfdb77e14.zip
Version bump, display complete certificate chain in FTPS, adds option for stateless local file editing, bugfixes
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog9
-rw-r--r--net-ftp/filezilla/filezilla-3.2.6.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index c384a8d65fac..a427ba6f7408 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.46 2009/06/24 14:30:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.47 2009/06/28 18:44:55 voyageur Exp $
+
+*filezilla-3.2.6 (28 Jun 2009)
+
+ 28 Jun 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.2.6.ebuild:
+ Version bump, display complete certificate chain in FTPS, adds option for
+ stateless local file editing, bugfixes
24 Jun 2009; Bernard Cafarelli <voyageur@gentoo.org>
filezilla-3.2.5.ebuild:
diff --git a/net-ftp/filezilla/filezilla-3.2.6.ebuild b/net-ftp/filezilla/filezilla-3.2.6.ebuild
new file mode 100644
index 000000000000..c80d6d5f16e3
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.2.6.ebuild,v 1.1 2009/06/28 18:44:55 voyageur Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus nls test"
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.9
+ >=app-admin/eselect-wxwidgets-0.7-r1
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=net-libs/gnutls-2.0.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --disable-autoupdatecheck || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}