summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-04-12 10:50:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-04-12 10:50:40 +0000
commit64194bbcdea8ec4c8ac8db71ff4127897c828328 (patch)
treeff45eb7d2cc8dfc76ded31a70285e2cd72db31cd /net-ftp/vsftpd/files
parentDrop akonadi use flag from 4.8.x and merge build options with semantic-deskto... (diff)
downloadgentoo-2-64194bbcdea8ec4c8ac8db71ff4127897c828328.tar.gz
gentoo-2-64194bbcdea8ec4c8ac8db71ff4127897c828328.tar.bz2
gentoo-2-64194bbcdea8ec4c8ac8db71ff4127897c828328.zip
Version bump thanks to Johan Bergstrom <bugs@bergstroem.nu>. Bug #411545
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/vsftpd/files')
-rw-r--r--net-ftp/vsftpd/files/vsftpd-3.0.0-Makefile.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-ftp/vsftpd/files/vsftpd-3.0.0-Makefile.patch b/net-ftp/vsftpd/files/vsftpd-3.0.0-Makefile.patch
new file mode 100644
index 000000000000..ab917209ea7b
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd-3.0.0-Makefile.patch
@@ -0,0 +1,34 @@
+Index: vsftpd-3.0.0/Makefile
+===================================================================
+--- vsftpd-3.0.0.orig/Makefile
++++ vsftpd-3.0.0/Makefile
+@@ -1,16 +1,16 @@
+ # Makefile for systems with GNU tools
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+ IFLAGS = -idirafter dummyinc
+ #CFLAGS = -g
+-CFLAGS = -O2 -fPIE -fstack-protector --param=ssp-buffer-size=4 \
+- -Wall -W -Wshadow -Werror -Wformat-security \
++CFLAGS = -fPIE -fstack-protector --param=ssp-buffer-size=4 \
++ -Wall -W -Wshadow -Wformat-security \
+ -D_FORTIFY_SOURCE=2 \
+ #-pedantic -Wconversion
+
+ LIBS = `./vsf_findlibs.sh`
+ LINK =
+-LDFLAGS = -fPIE -pie -Wl,-z,relro -Wl,-z,now
++LDFLAGS += -fPIE -pie -Wl,-z,relro -Wl,-z,now
+
+ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
+ tunables.o ftpdataio.o secbuf.o ls.o \
+@@ -26,7 +26,7 @@ OBJS = main.o utility.o prelogin.o ftpcm
+ $(CC) -c $*.c $(CFLAGS) $(IFLAGS)
+
+ vsftpd: $(OBJS)
+- $(CC) -o vsftpd $(OBJS) $(LINK) $(LDFLAGS) $(LIBS)
++ $(CC) -o vsftpd $(LDFLAGS) $(OBJS) $(LINK) $(LDFLAGS) $(LIBS)
+
+ install:
+ if [ -x /usr/local/sbin ]; then \